Syrinscape ProTip #24 - 3rd party integration


#1

Hey guys,

It seems I can’t get the 3rd party integration to work.

I copy the URL address, but upon trying to create a shortcut to it or using it in FG with the Sound Extension it doesn’t work.

Sounds that I manually created using the extension work just fine - and again, windows shortcuts don’t work,so I know it’s not an extension issue.

I’m using WIN10, with my only anti-virus being Windows Defender.
I didn’t mess with playback devices (yet).

I took a look at some other topics mentioning 3rd party issues but in those the problems seemed unrelated/vanished on their own.

Thanks for any help!


#2

Hmmm… Can you explain a little more what you mean when you say “Sounds that I manually created using the extension work fine”. I’m confused as when you create a sound manually in the DOE Sound Extension, you still need to copy/pate in a URL or sound link from Syrinscape for it to trigger. I’m attaching a copy of a sound I made to show the sound string from syrinscape. I’m sure you have done this, but always make sure that you hit the green “+” sign to finalize the entry. Also, remember the trigger is the purple clef and not the little brown circle (buckler). I’m sure you know this, I’m just puzzled as to what is working and what isn’t. We should be able to figure this one out!


#3

Hey Gwydion! Thank you for your response.

By manually created I meant sound strings that refer to local files on my HDD - this was the method I was using before purchasing Syrinscape. To create the new sounds I’m following up the same method as before (actually watched your video on this, thanks). Here’s an image just to double check:

I suspect the issue is not with FG or the sound extension because a) those other sounds I created that point to local files play just fine and b) if I create a Windows shortcut to the Syrinscape URL it also doesn’t work:


#4

You on Windows or Mac - Syrinscape’s 3PI does not work on a Mac


#5

Hi Dulux_Oz!

I’m on Windows 10 here.


#6

OK, so its not the known issue with Mac/3PI.

Well, in the tradition of “kicking the TV to make it work”, you could try uninstalling and then reinstalling Syrinscape (assuming you haven’t already done this). It sound to me as if Windows doesn’t recognise Syrinscape as the default program for the 3PI URLs - un- and then re-installing Syrinscape will reset that linkage, so its worth a try.


#7

Done, both installed and ran as Admind, but still no dice.

Not sure if this is the cause, but under “default applications per protocol” (not sure if this is the exact translation to english), Syrinscape does not show up.

I couldn’t find a method to manually add the Syrinscape association.


#8

Syrinscape doesn’t show up in my default applications by protocol either. One more hail mary… I use Kaspersky as my AV and not Windows Defender, but I just looked at the applications that are whitelisted for syrinscape and I see two. One is syrinscape.exe and the other is SyrinscapeURIProxy. Perhaps see if you need to create a rule to allow or trust Syrinscape URIProxy in Windows Defender? I haven’t heard of this issue before, but it might be worth a shot.


#9

Done, still no luck!
EDIT 1: Actually, I created an exception for the exe, I’m looking at how to create an exception for the SyrinscapeURIProxy .

EDIT 2: Tested in a different machine (Microsoft Surface Pro) and with real time Windows Defender protection disabled and still got zero results.


#10

Ok. I just looked at the full path in kaspersky and the full path is as follows:

c:\Program Files (x86)\SyrinscapeFantasyPlayer\SyrinscapeURIProxy.exe

Maybe try to whitelist that program? Again, I’m grasping a bit right now…


#11

Ok… Couple other basic things just for grins…

1 - Can you trigger sounds within Syrinscape itself? Have you confirmed the player itself is working on your computer and you hear sounds from it?

2 - As you many know, Syrinscape plays to your default playback device in windows. Is that set to your speakers?

3 - For the sounds you manually put together that work for you (not syrinscape), did you use the DOE sound extension or the DOE OLE extension?

4 - Is sounds turned on in fantasy grounds in the option menu?

That’s all I can think of right now!


#12

First of all, thank you for your continued assistance, Gwydion.

About your suggestions:

Added the SyrinscapeURIProxy.exe (the small 10kb .exe) as an exception to Windows Defender, but still nothing.

As for

  1. Yes, Syrinscape itself works perfectly

  2. And indeed, Syrisncape outputs to my desktop speakers, same as any othe media playback on my PC

  3. I used the DOE sound extension (not the OLE) to manually put together those sounds.

  4. Sound is turned on on FG, and I’ve tested with connecting with a second instance via Localhost.


#13

Have you tried using someone else’s sounds? Do you know anyone else who might be able to make an extension of their sounds for you to import and try? Also, it’s going to sound dumb, but are you clicking on the + symbol then checking the sound by clicking on the purple treble clef?
Also, I have found that I have to start Syrinescape before FG when I’m creating sounds - otherwise it seems really slow to respond.


#14

Hey 7th_serf,

I have’nt tried anyone else’s sound. I do click the purple cleft when testing. Just tested right now opening Syrinscape first and nothing changed.

At this point I’m pretty sure the problem lies in Win 10 itself; even when I tried to create regular windows shortcuts, mine end up looking like blank files:

As opposed to how Ben’s shortcuts turn out in this video: https://www.youtube.com/watch?v=2aM30zA9CLg


#15

I’m still thinking about this. Bothering me… Seems like perhaps it is a Win 10 issue. Did you stop and restart the firewall after you added the exception for the proxy.exe file? Maybe give your system a reboot now and try again? I’m running out of ideas!


#17

This is looking frustrating!!! Thanks for your help so far @Gwydion

Just for infos: Third party integration is working for me on my Windows 10 today.

SO if you run a 3rd party shortcut in the “run” command of Windows does that work.

Presuming NOT.

I’d definitely try an uninstall and re-install AND make sure you try and give access to Syrinscape through protective software.

NOTE: there is a separate little server app that listens for those 3rd party calls… so you’ll need to give it permissions too.

Other than that… I’ll keep think…

Anything helps

AND what is you main purpose for using the extension:

  1. to trigger within the Fantasy Grounds Window for conviences
  2. to get sound to your players?

#18

Ben, the separate little server app is the uriproxy.exe program, right?


#19

Hey Ben,

I’ll try uninstalling and installing a second time. I’ve whitelisted both Syrinscape.exe and SyriscapeURIProxy.exe, as well as the folder they are contained. Incidentaly, SyrinscapeURIProxy.exe is just 10 kb in size? Cause that’s what I have.

Pasting the the shortcut under “Run” indeed does nothing.

My usage case scenario involves both things you mentioned:
I trigger any sounds in FG itself (for convenience, as well as using the chatsound feature that triggers sounds automatically) and push those sounds through Discord so players can hear them.


#20

Went ahead and disabled both firewall and real-time windows defender protection (can’t seem to disable it completely.Syriscape is white listed on it), rebooted, but still nothing.


#21

Hmmmm…

Note: I haven’t had a report of a similar problem literally ever… so we are definitely looking for something unique to YOUR system.

I haven’t even had a few reports since a Windows update or anything.

Not that that helps you!