Syrincscape & Discord, using VoiceMeeter Banana to master the game


#1

Hi Everyone!

I am a new Syrinscape user and wanted a way to play it via Discord to have greater atmospheric control of my D&D 5e West Marches campaign.

I have seen some great guides on setting up Syrinscape to play via Discord with Voicemeeter and the virtual cables. However, using Voicemeeter Banana you can achieve the same result with less software/drivers required.

Step #1: Installation

Step #2: Housekeeping

  • Launch Voicemeeter Banana and click the “Menu” button (top right) and click “System Tray (Run at Startup)”.
  • (Optional) Select “Show App On Startup” (Helpful if you want to have quick and easy access to make changes on the fly)

Step #3 Windows: Configuration

  • Open Control Panel > Sound
  • On Playback tab, right Click “VoiceMeeter Input” and select “Set as Default Device”
  • On Playback tab, right Click “VoiceMeeter Aux Input” and select “Set as Default Communication Device”
  • On Recording tab, right Click “VoiceMeeter Output” and select “Set as Default Device”
  • On Recording tab, right Click “VoiceMeeter Aux Output” and select “Set as Default Communication Device”
  • On Communcations tab, select “Do nothing”

Step #4 Discord: The Basics
Go to Discord > “User Settings” > “Voice & Video”

  • Click “Input Device” and Select “Voicemeeter Aux Output”
  • Click “Output Device” and Select “Voicemeeter Aux Input”
    ^Yes, these are purposfully the opposite of Input/Output and Output/Input

Step #5 Voicemeeter: The Basics
In Voicemeeter

  • Select “Hardware Input 1” and select your microphone
  • click “A1” and select your primary speakers/headphones.

Step #6 Voicemeeter: Comprehension
A1 = Your Headphones/Speakers
A2 & A3 = Can be ignored for now
B1 = Virtual Output 1 (VoiceMeeter Output)
B2 = Virtual Output 2 (VoiceMeeter Aux Output)

Hypothetical Setup #1 (Microphone audible to Discord, PC Audio audible to you ONLY)

Hypothetical Setup #2 (Microphone audible to Discord, PC Audio audible to Discord)

(Recommended)
When playing Syrinscape over Discord you will want to make some adjustments to Discord settings:
Go to Discord > “User Settings” > “Voice & Video”

  • Disable “Automatically determine input sensitivity” and move the slider to the far right.
  • Disable “Noise Suppression” a.k.a “Krisp”
  • Disable “Echo Cancellation”
  • Disable “Noise Reduction”
  • Disable “Automatic Gain Control”

Hopefully this helps you lovely ladies and gentlement lift your atmospheric game GM’ing your game of choice in these “uncertain times”.

Cheers,
TheUselessKent


Is Roll20 Integration happening?
#2

VoiceMeeter is great software, but I’m wondering what advantage this gives over using Discord’s livestream feature to just capture the Syrinscape player. This is the method that I use with my group.


#3

VoiceMeeter is great software, but I’m wondering what advantage this gives over using Discord’s livestream feature to just capture the Syrinscape player. This is the method that I use with my group.

In combination with a Virtual Table Top (VTT) such as Fantasy Grounds or Roll20 it’s much more useful. You don’t need to stream or cast any visual content to them, they simply access the VTT from their computer and join Discord.

This way you get all the benefits of great ambience from Syrinscape without the need to stream.


#4

I use Voicemeeter Banana with discord and FoundryVTT (or Roll20 still, for now). It’s super cool.
My only problem with it is that since I started setting up Voicemeeter on a second laptop I sometimes get robotic or garbled, distorted sound from the microphones (both decent USB microphones that work perfectly) for no apparent reason. If I bypass Voicemeeter and select microphone straight as discord input, the sound goes back to normal… Maybe I played with the wrong setting somewhere? I’ve no idea.


#5

If you want to post some screenshots of your instance I can review or join my discord and I can review over the weekend.


#6

Blockquote
setting up Voicemeeter on a second laptop

I suspect this is because your laptop is going into Sleep/Hibernate mode and it’s not recovering the Syrinscape Audio Engine.

I have two tips for this:

  1. Update your laptop BIOS and Drivers using the utility from the manufacturer.
  2. Restart the Audio Engine via Menu each time this occurs.

#7

Thanks, I’m sorry I don’t have the time to properly troubleshoot this. If it was an easiy identifiable issue I would, but after spending an entire afternoon on it I’m pretty sure it goes beyond settings or setup and maybe related to bugs with one of the sound cards which is a custom hardware with crappy drivers that can’t be upgraded (because laptop distributors are essentially evil).

But thanks for the suggestions!


#8

No problem at all. If you ever change your mind or want to ask a question, feel free to hit me up on discord. Good luck!


#9

THanks EVERYONE here for being so positive, helpful, friendly!

Let’s keep this vibe going as the general theme for these forums… it makes for a nice place that I feel happy to drop into without hesitation! :slight_smile: :smiley: :beers::pizza: