Using offline players with Elgate Stream Deck

I purchased Elgato Stream Deck XL and I have been setting it up for work, but now it is time for the hobby stuff. I am not sure how to use the 3rd party integration from the Sci-Fi and Fantasy Players. Using the online player is no-go for bandwidth reasons, I want to use the local copy of the soundsets.

I didn’t have success launching it as URL from the System library, so I presume some hack is required. Some suggestions?

Don’t have the offline player installed right now, but hitting “enable 3rd party integration” in the app adds plus symbols to everything. Click these symbols and a URL will be copied to your clipboard. Call the URL in the Stream Deck to activate those sounds.

But which option from Elgato sidebar to use to call the URIs?

URI’s are weblinks so you would use the “website” option

Yup. And make sure you check “access in background” so the call doesn’t open in your default browser.

Works?

When I drag the “Website” resource from the System category and put the URI in the URL with “Access in background” checked, nothing happens.

When I remove the checkbox, windows prompts me to find app in the store that can open such kind of link. Obviously there is no such app, so I wonder what is the hack here.

I don’t see any option in Syrinscape offline players to register them as handles for such kind of resources. There is no option in the Settings app to register such thing manually and should be done by the application programmatically using Windows API which I am not familiar with. Starting the player in Admin mode also does not help.

That should be working. Can you paste one here so we can see?

This is how it is set up in the app. The URL is the one taken from the app by clicking the + symbol next to a sound set: syrinscape-sci-fi:moods/bW91bnRhaW5zLW1hZG5lc3M6OkNoaWxseSB3ZWF0aGVy/play/

I see you’re trying with the sci-fi player. Does it work with the fantasy player? I just tried it now, not even logged in (using one of the demo soundsets), on the fantasy player and it works WITHOUT “access in background” checked. With the online player I need this checked, but it doesn’t work at all with the fantasy player when checked.

I just installed the SciFi player and tried one of the demos. Didn’t work; get a popup saying I need a new app to open the link.

Yes, the Sci-Fi player does not work, I tested with 1 link in Fantasy and all looks good there. :open_mouth:

Looks like this is a job for the devs then, my fresh install had the same issue.

Yes, little nasty bug. I hope this is fixed as soon as possible :slight_smile:

Do I need to report this problem in some formal way or the devs will pick it up from here?

@Valyar Does the syrinscape-sci-fi:// URL work, if you just paste it into a browser instead of attempting to trigger it via the Stream Deck?

The Sci–Fi player URLs does not work in browser or when launched via the Run utility. Only Fantasy player and its proxy seem to be registered in the system.