Syrinscape ProTip #05 - Setting Cache location (on PC)

Can I change the storage location of the Syrinscape Cache = all the SoundSet data?
Here’s how you can do it on PC (only do this if you are confident with cmd line and medium level system hacking)…

  1. Cut content from “C:\Users[yourUserNameGoesHere]\AppData\LocalLow\Syrinscape” and paste it into [The full path where you want to put the data instead… eg “H:\SyrinscapeFantasyPlayer\SyrinscapeSoundData”]
  2. Delete “C:\Users[yourUserNameGoesHere]\AppData\LocalLow\Syrinscape”
  3. Open a cmd.exe with admin rights.
  4. type in: “mklink /j C:\Users[yourUserNameGoesHere]\AppData\LocalLow\Syrinscape [The full path where you want to put the data instead… eg “H:\SyrinscapeFantasyPlayer\SyrinscapeSoundData”]”
  5. press Enter
4 Likes

So, tried this and now the player seems to think I have no soundsets installed. I’m using Windows 10 if that makes a difference.

EDIT: Ok, after many hours, got it to work. Turns out my files were in the Cache folder and needed to be in the Chapters folder.

1 Like

@starwind1985

Thanks for noting the fix… might just prove useful for someone else.

You win :rice_cracker: :pizza:

1 Like

Okay, that seems to have worked for me. Thanks!

While it is great that this hack is possible, wouldn’t it be so much nicer for you to allow us to set that preference in settings?

2 Likes

Yes, we’ll definitely do this at some point if it becomes possible. Last time I looked it was a Unity thing that wasn’t changeable. We have a ticket that makes us have a quick look back at this periodically, so maybe Unity will make that possible at some point. :slight_smile:

1 Like

Is there any Mac solution? I would love to offload the Syrinscape SoundSet data to an external SSD.

This did not work for me.
I used: mklink /j C:\Users[my userid]\AppData\LocalLow\Syrinscape D:\Syrinscape Sounds

I keep getting “The syntax of the command is incorrect.”
I even looked up the syntax. Not finding an answer.
I realize this is an old post, so I will keep looking for syntax changes that may have happened over the years.

The “slash” after “Users” was there it just is not displaying in this post. Probably a formatting thing. Tried to edit it and it still would not show. FYI

I’ve had no luck trying this. Can I be shown the entire syntex and wording without all the unneeded stuff? Meaning just what i put into cmd? I’ll insert my user name. Thanks

Nevermind! been awhile and forgot my syntex rules, but got it

1 Like

Thank you for the reply

Title says Mac and Unix - but the only solution posted is Windows.

Oop! Thanks for that. Fixed now. :slight_smile: