[RESOLVED] Distance Slider Does Not Work on Some Elements


#1

Whether I set the slider to 0m or 250m, the volume is exactly the same. I tried creating a new Soundset to troubleshoot with the same result. The length of the samples in the element doesn’t seem to make a difference, but the ones that are broken tend to be longer.

RESOLUTION:
Check “Enable 3D positioning?” for both the element AND the sample (see below for images).


#2

Bump. I still have not been able to resolve this problem.


#3

Have you checked the 3D positioning in the element and in the sample properties?

Also: you mention that the distance setting tends to not work on longer samples. Do you have an estimate on the length of the sample when the setting seems not to work?

Does this happen with official samples as well or only on self-created ones? If the former are affected - do you have an example?


#4

Hey @m.bottorff.ii

Sorry this got missed!

Wanna let me know the name of your SoundSet and I’ll take a look and see where the prob it. :slight_smile:


#5

Great questions. I’ll try to help you narrow this down.

Yes, 3D position was checked.

The length doesn’t seem to be the cause but there does seem to be a correlation. Samples as short as 38s don’t work, but some as long as 147s do work. I have yet to find a sample that is shorter than 15s not work though, which is why I say length seems to be a factor.

These were all official samples. Here are some examples:

WORKS

  • Brindol Town, Market, ENDFADELOOP Turkish Market (147s)
  • Bustling Port Town, Happy Rich Murmuring, Tavern Loop Germans (58s)
  • Bustling Port Town, Watermill Machinery, Watermill 2 (63s)

DOESN’T WORK

  • Brindol Town, City Square, ENDFADELOOP_Market Place (185s)
  • Bustling Port Town, Street Noises (57s)
  • Bustling Port Town, Business in the Streets, Good Venice Ambience - events 1, 2, and 3 (94s, 82s, and 114s)
  • Bustling Port Town, Busy Marketplace, Enclosed Market (66.3s)
  • Bustling Port Town, Dock Ambiance, Kids playing 2 (63s)
  • Bustling Port Town, Very Busy City Ambience, Kids playing_the-innocance-of-youth (624s)
  • Bustling Port Town, Angry Crowd, Angry crowd 02_crowd-shouting (38s)
  • Bustling Port Town, Concerned, Dragon’s Demand Concerned Crowd (113s)

#6

Okay, this is very helpful. If you watch closer - there are TWO places, where you have to adjust the 3D positioning. One place is the ELEMENT inspector (which you have probably checked for 3D) and the other place is the SAMPLE inspector. If the sample itself isn’t marked as 3D positionable, the element inspector might be checked, but won’t handle it. You have to enable it in the sample inspector, then it should work.

Check out these screenshots, that illustrate the setting.

I hope, this helps. If you want those files positioned in 3D, just put them in a self-created element into your soundset and check the box. Then it should work as intended.

:smiley:


#7

Thank you! This is what I was missing. Sorry if this was common knowledge. I tried searching for my problem and didn’t find any matches. I will mark as resolved.


#8

No need to be sorry, that’s why we are here. It is a setting that gets overlooked at times. Even we forget about it quite regularly. :see_no_evil:


#9

@sonofconan is there a way to make it that when you click the 3D positioning checkbox in elements a pop up asks if you want to make the same change in properties? It might help avoid this in the future.


#10

Yeah, some kind of logic between things that position a sample would be useful.

Also, perhaps moving the Is_3d property to the sample ENTRY in the Playlist rather than it being global on the Sample itself might help.

Noted for further looking intos.


#11

Follow-up Question: Is 3D positioning available for all samples? Or, are certain samples locked from duplicating/editing?

I’m having trouble with some samples telling me that they are “used in official” content and won’t let me edit, even when adding it to a new element, new sound set. As an example, I can’t duplicate/edit “Raucous tavern L 1.”


#12

It takes a few minutes after duplicating to unlock it. Try reloading and it should be editable.


#13

No luck. Tried duplicating, creating a new sound set, copying to the new sound set, and duplicating it there. Refreshed, closed down the editor and reopened, waited an hour and tried it all again.

There may be others, but the samples that I know are causing troubles are:
Baldur’s Gate ambiance… 1 through 4
Baldur’s Gate Town Ambiance… all variations
General Hubbub DnD
Raucous tavern L 1 through 3
Raucous tavern R 1 through 3


#14

Hmm, would you mind comparing your steps with mine?

  1. Create a new soundset
  2. Create a new mood within that soundset
  3. Create a new element in that soundset
  4. Go to the Library/samples and search “Raucous travern L 1” (that should come up with several results)
  5. Click the plus next to the sample of your choice while having the element highlighted in the main window.
  6. Check if the said samples shows up in the element playlist.
  7. Click on the sample in the element playlist.
  8. Go to the sample inspector and change the 3D settings.

It SHOULD work like this.


#15

Nope :confused: I wonder if its a problem on my end somehow…