Online Player Update?


#1

Is there an update going on for the Online PLayer? I know the macs don’t always play well together but all I get is the logo splash screen and version number. Even after closing/reopening and re installing + closing/reopening.


#2

Myself and all of my players are complaining of this right now as well.

Tech support!

Halp!


#3

@sonofconan @benjamin I think your toy broke. :bug:


#4

I just connected again. I guess the servers just needed a breather.


#5

I blame actual GOBLINS! :japanese_goblin::crossed_swords:

PS And no, we were NOT doing an update… might have been:

  1. a bump in our host
  2. one of our servers jamming and auto-restarting (which they are supposed to be able to do now)… so that would be YAY!

@sonofconan anything in the logs?


#6

OK> Definitely something fishy going on. It’s playing up for me.:face_with_thermometer:

We are taking a look!


#7

Looks like all of my players were able to connect, it just took a while.

My online player as DM never connected, but oddly when I opened the Soundset Creator my Online Player immediately connected, so I wonder if there was some sort of weird authentication token hiccup or something.

Session went off without a hitch though and everything worked great :smiley:


#8

Yay! :slight_smile:

Yes, there are some interesting errors coming through, but it seems like, for the moment, just persisting seems to get people through. :facepunch:


#9

Not to necropost (though it’s only been a week), but I figured I’d load the Online Player early before my session in a few hours, and I see the lame behavior I was seeing last week.

The online player is just stuck at the initial screen. I’m not sure if this is just traffic related or what, but since there’s no feedback on the initial loading screen it’s hard to say :slight_smile:

@benjamin are there any client side logs I can provide or anything?

EDIT: It did eventually load for me, though it looks like it took about 2 minutes.


#10

I’ve just had the same issue myself so it does seem to be the same problem as last week. The server is seeing a LOT of weekend activity. It is something that we are looking into so it should be resolved very soon, sorry for the inconvenience!

As the Online Player rolls out of Beta we are adding more servers to keep up with the people using the Online Player but it looks like a lot of us are currently trying to play online, much more so than normal :face_with_thermometer:


#11

Another question - possible related? The Stop button at the top of the Master Interface isn’t working properly. If you use it once to stop all sound, it grays out and stays that way.

So, there’s essentially no way to stop the sound.


#12

Yeah that sounds like its the same issue, the stop command is getting caught up in the lag. Thanks for letting us know, we shall do some digging!


#13

Hi all, so a quick little update. We’ve given the server a gentle kick, so the Online Player should all be working smoothly again.

We’ve also increased server capacity to better handle peak demand, and will continue to monitor the performance.

Increased demand = good, server lag = bad! We will keep an eye on things but please do let us know if you have any further problems :grin:


#14

I suppose there’s a big jump in people playing remotely?! :smiley: :persevere:


#15

Everyone wants to battle that Corona Monster


#16

Sorry if this is the wrong place, though the title seems relevant…

I tried to install the Online Player this morning and got the following message:

“Syrinscape Online Player” can’t be opened because Apple cannot check it for malicious software.
This software needs to be updated. Contact the developer for more information.
This item is on the disk image “syrinscape-1.4.6-20200115-mac-online.dmg”. Chrome downloaded this disk image today at 9:33 AM from www.syrinscape.com.

Any chance I’m just doing this wrong, this is an anomaly, or has Mac just changed something recently?


#17

We have many people using Syrinscape on Macs, but, yes, Catolina objects a bit with a few warnings and often blocks the first run.
First give this a try:

  1. Shutdown Syrinscape completely
  2. Restart your system
  3. Restart Syrinscape
    If you have no luck with that, then check you are running it the best way for the OS:
  4. download the DMG and drag the app to /Applications folder (ie don’t run it from inside the DMG)
  5. right click and select open instead of double clicking to launch the first time
  6. if Catalina asks for additional weird permissions (eg to monitor keyboard input), you can deny… We think this is due to the version of Unity this build is running on, and we do NOT and do NOT need to monitor keyboard input while the app is not active
  7. if it appears to be stuck, quit and re-launch the same way

This is an issue we are working on, and it will be fixed with our next released version.

Let us know how you go! :slight_smile:


#18

Sorry, it took me a day to get the chance to do this. Unfortunately, I didn’t have any luck. I’m still getting the

Syrinscape Online Player” can’t be opened because Apple cannot check it for malicious software.
This software needs to be updated. Contact the developer for more information.
This item is on the disk image “syrinscape-1.4.6-20200115-mac-online.dmg”. Chrome downloaded this disk image today at 9:33 AM from www.syrinscape.com.

message. Any idea how long before the updated next release might be?


#19

@maxx2298 I just tried this myself in a Catalina VM. I got the same result as you the first time I attemtpted to “right click and select open” (from the /Applications folder). But, I just repeated that step (5) immediately after and while it gave me the same warning again, it did allow me to open it the second time. I also chose to deny the request to monitor keyboard input.

We are working on an updated build for Catalina, but in the meantime the above should work.


#20

I’ve tried again a few times, but haven’t been successful yet. I’ll look ahead for the update.

Thanks!