Can't play sound out of the online player - Resolved


#1

Hello, I’ve paid for a subscription and followed the instructions to get my party to hear the sounds I am making over syrinscape with roll20 running side by side. I’ve been trying to test it out today on my machine (before my game on tuesday) but can’t hear a thing. Youtube works. I’m using Chrome.

Thanks,

Nathan


#2

Also clicking ‘Help’ in the menu shows a dead link.


#3

The Master Interface allows you to trigger and control the sounds, but you will also need to run the Syrinscape Online Player to actually hear the sounds. Run the Player App, link it to your game by the Control Panel and then trigger your sounds in the Master Interface. Everything should then work for you :slight_smile:

Instructions for setting it all up can be found HERE


#4

Thanks Steve. I’m away from my computer at the moment but will I be able to hear anything my end?


#5

Hey, so I’ve tried to play it tonight and the sound effects are really quiet for my players, even when they turn the volume right up. I can’t hear anything at all, even when I put the volume up really high?


#6

We tried again and again but the online simply wouldn’t work. I followed the instructions carefully (as far as I’m concerned) and I can’t hear a thing. The players online said they could but very faintly even at max volume on the interface.


#7

I got it working! I didn’t realise you needed to have the Online player downloaded, open on your mac whilst you had the master interface in the browser open and playing sound effects at the same time. When you have time can you make this clearer in the instructions please :slightly_smiling_face: thanks a lot.


#8

Excellent, glad you got it working

I did mention above that you would need to run the Syrinscape Online Player to be able to hear the sounds you trigger with the Online Master Interface, but at least you’ve got it working now :slight_smile:

This week we are rolling out some additional changes to the Online Player as well as the new Creator. Once those are done we will be making some new guides and videos, which should make it much clearer and easier to use!

Thanks for your patience!


#9

Hey guys, if you’ll accept some feedback from a friendly UX professional - the interface of your Master Interface suggests very strongly that someone should be able to hear the sounds. when you click on an icon, it turns blue. There is a volume control at the top of the screen with a stop button next to it, and also… it’s a sound application. The user expectation is going to continue to be that people can hear the sounds when they click on them from the online interface without additional things being set up, no matter how many times you tell them otherwise in instructinal text because the interface cues you have provided lead very strongly to this conclusion. You’re going to have people constantly telling you that something is broken. I’d either take out some of the UI elements that indicate that sound should be playing (the volume controls) add a warning message prominately at the top of page with a clear link to what they need to download (I still haven’t figured that out myself yet) or (best option) fix the interface so it works as expected and plays stuff when people click on it. Sorry if I’m telling you things you already know, but this is going to cause you a LOT of support grief here on the forum if you don’t address it soon! Good luck and congrats on the launch of this huge new interface! Remember, if people aren’t complaining when you launch your MVP, you waited too long to launch! LOL.


#10

Ok, I THINK this is a legit bug. I downloaded the player for macOS and opened up the app. I’m just seeing a screen with a storm image at the worlds “Syrinscape” and “Version 1.4.2…” That’s it… there’s nothing else I can seem to do here. I’m guessing from the screenshots in your instructions that I’m supposed to be able to input a code here? For me at least, I’m not seeing that option. (See attached screenshot) I’m going to hop over to my PC and see if I can do it there. Maybe I’m still missing something…


#11

Aha! Yes! Got it working on my PC. This is definitely a bug in the MacOS player.

For general users who are confused about the need to open a media player first, a suggested quick fix for users like Nathan and myself - add a “Sound not playing?” tooltip hyperlink in the top bar near the volume area of your master interface (this is where I kept looking and clicking to try to make it work). Take them to instructions like, “You must have the Syrinscape online player downloaded and open in order to hear the sounds played through this Master Interface. To download the player, go here.”


#12

Add me to the list of people who can’t get this to work. I think the account is linking, but it’s not clear. I run the player and it brings me to the website where I log into master player and nothing happens. All on iOS. Will there be a post when an usable tool is available again?


#13

hey @tai_admin Let’s Discuss @katie.hawkey’s ideas re "giving people a clue that they have to run and correctly LINK the Online Player to actually hear the sounds they are clicking.

Though… we do bring up a warning message don’t we… when there is NO linked player…

Hmmm… either way… let’s discuss! :smiley:


#14

As a user, the more information I have the better. Spent about an hour and a half troubleshooting your system today, going back and forth between my Mac and PC. Some of it was my mistake, but your system is very low on error messages, error prevention and useful feedback to help users recover from the errors they make. Even if the message had shown 'this isn’t available on Mac yet" I would have been grateful as it would have saved me a TON of wasted time trying to figure out if it was my mistake or a buggy/not-working-yet system.


#15

@katie.hawkey is this still the case for you on macOS? If so, can you provide your macOS version and hardware model (including the year of manufacture)?

It is working for me on macOS, but we have had issues in the past with compatibility across older Apple hardware, even when running the same version of macOS.


#16

I just redownloaded and reinstalled and Im seeing the same blank load screen with no option to input a code.

Screenshots of my specs as well as showing the blank load screen. I do have an older mac, so maybe that’s it.


#17

Simple close it and open it again. Does it go through this time?

@katie.hawkey


#18

@katie.hawkey When the app hangs on this loading screen like this it is typically because of a network connectivity issue.

Are there any outbound firewall rules active on the Mac or router? The app needs to connect to www.syrinscape.com on port 7977.

From a terminal window, can you attempt to connect to port 7977 with telnet?

$ telnet www.syrinscape.com 7977
Trying 52.38.144.42...
Connected to syrinscape.com.
Escape character is '^]'.
^]
telnet> quit
Connection closed.

(press CTRL-] then type quit to break out of the connection.)

You could also try the old (offline) creator https://syrinscape-us.s3.amazonaws.com/files/Syrinscape-SoundSet-Creator-macOS-0.8.2-20170322.dmg … it also has a player app that connects to the same server and on the same port, but was built on a different (newer) machine.

If the old (offline) player app can connect, but the new (online) player app cannot, then it might be a problem with the build machine we used this time.


#19

@katie.hawkey Could you also try creating a new user account on your Mac and launching the Syrinscape Online Player app when logged into the new account?

I’ve just tested the online player in a fresh install of macOS Sierra in a virtual machine and it is working for me (brings up the PIN after showing the splash screen).

I’ll also try the virtual machine on an older machine, next.


#20

As a fellow UX proffessional, I was too lazy to give feedback, but this is quality feedback :clap: MVP products like this rely on our feedback to make things better. Thank you for your diligence and thank you for the standard of feedback, I wish I could get that level in my workplace.