Can't play sound out of the online player - Resolved


#21

I’m on a similar spec machine and I had to close it and open it a few times to get it to work,


#22

@katie.hawkey we reproduced this behaviour on multiple machines (new, old, virtual) running Mojave, High Sierra, and Yosemite.

The issue always occurs the first time we attempt to run the app after downloading, when we are prompted by macOS if we are sure we want to allow it because it was downloaded from the Internet.

If we run the app from inside the disk image, we are prompted every time (because the app bundle inside the disk image is read only), but it works if we tell macOS to never prompt for files on this volume, or on the second attempt to launch from /Applications after previously allowing it to run when prompted.

Can you confirm that you are seeing the app hang every time you launch it, from /Applications, and that you are NOT being prompted to allow the app to run because it was downloaded from the Internet?


#23

Ah. I was being asked each time. I’m away from my computer, I’ll try this over lunch.


#24

Boo. Sorry, I just launched it from my Applications folder and it did not ask me to confirm but it’s still hanging (I did see it flash the interface for a fraction of a second, but it’s now just the lightening image)

Its also not closing well after the 2nd time I open it. I have to force quit it each time. I even tried reinstalling it and opening and closing it a couple times. Same behavior, loading screen only each time. Have to force quit second open and beyond.


#25

Hey @katie.hawkey :slight_smile:

Is this still NOT working for you?


#26

@nathanl84 @katie.hawkey @brianleet

We’ve just rolled out an update that hopefully makes this really obvious. If you attempt to access the master interface without an active Syrinscape Online Player connected, the master interface will be blacked out with an alert that says:

Audio playback is unavailable. You have no active Syrinscape Online (beta) Player connected. Download for Windows, macOS, iOS, or Android.

We previously had a similar alert that only showed up when you had no active device (connected or not), and the alert was dismissible, and the master interface still accessible.

We’ve also improved device linked/unlinked, activated/deactivated, connected/disconnected notifications in the activity log (visible from the control panel).

To be clear, you must:

  • Link the Syrinscape Online Player running on a device (Windows, macOS, Android, iOS) to your account:
    • Click the link from the app and login; or
    • Click the link in the devices list from the control panel and enter the PIN shown in the app).
  • Open the master interface AND launch the Syrinscape Online Player app on a linked device.
  • Click the “activate” button on the app, if prompted. You can have multiple linked devices, but only one active device.

@brianleet is the above still not working for you?

@katie.hawkey is the player app on macOS still not working for you (unable to connect, same as on first launch when macOS prompts if you want to allow it because it was downloaded from the internet)?


#27

FYI - I am having this same exact problem. it seems that on macs, the pop ups that come up on launch of the app in windows (asking to agree to the license agreement) for whatever reason don’t come up when you launch the app on a mac - without being able to agree to the license, the software effectively gets stalled. Is there any workaround for this? hopefully that info helps the devs and they can work on a fix. I hate using PCs.

UPDATE - downloaded the app to my ipad then linked my ipad to the acct. this solved the no audio player message, sooo… I can do everything on my mac to edit soundsets etc, but all of the sounds play out of my ipad (as long as the ipad app is up and running). Not the best scenario (which would allow for master interface/soundset access AND sound to all work all on one machine), but at least it works and I don’t HAVE TO use a PC.


#28

@t.sheetz13 This doesn’t sound like the same issue.

On Windows, the app has an installer that you click through a few steps and view the license.

On macOS, you open a DMG that contains an app bundle and the license and you install the app by dragging it to your Applications folder.

There is a known issue where the first time you try to launch the app from your Applications folder, macOS will ask you if you want to allow it because it was downloaded from the Internet. Even after confirming that you do want to allow it, the app will not connect on this first launch as the prompt has blocked the app from accessing the internet.

Quit and relaunching the app a second time should no longer prompt you for confirmation and the app should be able to connect.

The other issue being discussed here is that it was not obvious you needed to run a linked Syrinscape Online Player app on the device where you want audio playback to occur AND the master interface in a browser on the device where you want to control it from.

That issue should be resolved now as we display a persistent warning explain that audio playback is not available without an active and connected Syrinscape Online Player app, and otherwise deny access to the master interface.

Can you double check that you are launching the app from youApplications folder and that macOS is NOT prompting you for confirmation? The app should then display a PIN that you can enter via link at the bottom of the “Your Linked Devices” list on the control panel to link with your account, and then it should display an activate button that will make your Mac be the device where audio playback occurs.


#29

I have been trying to make this work, I have my paid account running the sound as the GM, and created a free PLayer account on a second device. Both have the Online Player running. The GM Online Player shows that it is broadcasting the music form the Master Page in my web browser. However the Online Player on the second device doesn’t seem to be receiving any sound, but it does show it’s connected to the GM Player.

Not sure what i’m doing wrong.


#30

@dumrobot.ed.7 Does the online player for the second account/device change artwork when the GM plays a mood in a new soundset? Does the activity log update when the second account accepts an invitation to join the GMs game?


#31

It was not showing the artwork for the second account/device and the activity log showed the invitation being accepted to join the GM’s game.

I seem to have it working now, I needed to connect the GM’s Player first and proceed to the Master Screen. Then had to open the second account/devices Player. I had to link the second account/device as the primary, then unlink it, after that I could link the GM Player again and it would allow the music to stream properly. I think this might have to do with how the servers recognize my computers.


#32

It’s because the plug was plugging the plug plug with a plugged plug of plugging.

Glad you worked that out! :wink: :smiley:

I really don’t understand computers sometimes! :eyes:


#33

Following this thread to see if there are any updates- after subscribing and falling in love with the programs, I can’t seem to get the Online Player to work on the “minion” end.

Music plays just find on my Windows laptop with the Player/Control Panel combo as the GM, but we can’t get the music to play on my husband’s laptop as a player. It will work on his phone, but since we’ll be using this with several other online players on various operating systems alongside Roll20, phones are not ideal. Glad we tested this in person together first.The Online Player is showing him as “connected” in my game, both when he logs in via laptop or phone. He’s closed out of the player (with difficulty) and restarted/reconnected it several times.

Any suggestions would be much appreciated. I was really excited to use this, :frowning: Hoping patience will pay off. I saw mentioned in another thread that the influx from GenCon (myself included, hi!) could be making things a little clunkier? Should we just give it some time? Thanks so much!


#34

@lyn.basham When the GM plays a mood, does the GM and minion player apps both show artwork for the soundset being played? But just the minion app doesn’t make any sound? Does the spectrum analyzer show any activity in the minion app?

UPDATE: Could you also DM me the secondary device’s account name so I can investigate?


#35

Hey there!

Only the GM player displays the artwork and spectrum analyzer activity. Nothing on the minion device. I’ll be happy to DM you the second account. Thank you for the reply!