Where did my work go?


#1

Yesterday I spent a couple hours copying existing soundsets, manipulating them, and making them just right for a campaign later that evening. When I got to the game, my work wasn’t there. The copied soundset was there, but all my modifications were not.

It must have been those damn error 400’s that I keep getting, EVERY, SINGLE, TIME, I work on soundsets. I believe that once again, they get created by moving and reorganizing items.

These errors and issues need to go. I get that this in Beta, but I am getting to the point where I just don’t want to use this tool anymore due to the issues that crop up during creation and manipulation.

When it works, it works great.

@sonofconan, I have provided you a bunch of troubleshooting data that I hope was helpful about 10 days ago; I have not heard anything yet, but know you were out of town last week. If there is ANYTHING I can do to help you, please let me know.

This is very frustrating, because when I get those error 400’s (or variety of them), I never know what will be broken or missing in the end.

Thank you.


#2

Hmmm… I’m just NOT getting these when I am working in the Online Player UI.

@Steve @new_vision @ominousbarry You guys?


#3

It doesn’t happen during game playback, only when designing.

I think I’ll start recording my sessions, so when the problems surface, I’ll pass them along.


#4

The 400 error are a product of clicking things too fast. Yes, I find them annoying too. I get excited about creating sound and I am zip, zap, whiz, slap, bang my soundsets together. Forgetting that this is all online. Each action takes time to upload. Slowing down has reduced the amount of 400 errors I see.

This plays into the 'things going missing" aspect. I have inserted elements, that later are no longer there. Again, this is because I have been working too fast and not allowing the OLP to upload the new data.

I have requested a normal version of the app, that is installed on my computer. So when I am creating a soundset, I can work to the speed of my PC and not the speed of the internet. But having the library online, which is the greatest part of being on line.


#5

Yes! To work safely keep an eye on the little blue line that makes its way across the top of the browser when you do things… let a task complete before you do the next one.

Take your time.

Let us know if that helps you @dorpond :pray:


#6

I haven’t had a 400 error in ages, and yes, it depends on your work speed. When you say manipulating, reorganizing and moving @dorpond - you mean altering playlist of samples, sorting elements, moods and samples, that sort of changes?


#7

Every time I work on soundsets, I have issues, and I know for a fact that this last time I did not upload any files. Usually I do, but this last time I did not.

This last time all I did was copy an existing soundset, went into that soundset, went to the library and searched for warning horns of such, auditioned a few, found one I liked and added it.

Then I played the existing mood, and tried to find a place for this horn but then decided to create a new mood. Then I started turning on elements and adjusting volumes, then moved elements around so that they were grouped more logically, then I moved the mood up higher on the list.

Then finally, I moved the soundset higher on my list so that I could find it easier during the session that night (I don’t like the current process of having to get out of the creator to add things to campaigns, so I no longer do that)

Yes, the little wheel was the only thing that was spinning, there were no blue lines or uploads going on, but I had the impression that the little wheel spinning was only for getting everything ready for download to the client app. In fact, I could have sworn I was told that we could even close everything while the little wheel was spinning and that would be OK because the server was processing all that, not anything on the client side.

So that was last design session, but I have issues all the time that are easily reproducible, that have nothing to do with moving too fast. Let me snag one to show you.


#8

Here is one that clearly breaks after I upload a single file. This one doesn’t trigger a 400, but you can see that audition doesn’t even work anymore. I mistakingly didn’t capture audio in this video, but not only doesn’t the play circle show or move any longer After an upload, they also don’t play sound any longer. If I switch to a different element, those will audition, but when I switch hack to this One-X auditioning is broken.

I opened up the dev tools to help you guys, but bugs like these trigger all the time during my creation process. I’ll keep capturing videos of things breaking, next time with audio.

https://1drv.ms/v/s!At5zujwlL9dBnNpdx4AI7B_vsTLsGg


#9

Oh, and if you say it is caused by the wheel spinning on the new upload, I will tell you that the file was a 12k wav file, and those little wheels spin Forever. If you come back and tell me that I need to wait for spinny’s to stop every time a spinny spin spins, I will tell you that I will not create anymore, because those spinny’s take forever to finish - my time is way too valuable to sit and stare for a half hour. I have had spinny’s spin for close to an hour sometimes.

I sent the files I used in this video, to @sonofconan.


#10

I just did a bunch of testing, doing the same things that I did the day of the errors, and I couldn’t reproduce them. I am on S2, so I will switch servers to see if it is a specific server issue. Stay tuned.


#11

OK, I switched to S0 and in about 14 minutes, I was able to show some of the annoyances that I face, every single time I sit down to create. Again, this is just some of the issues I face, there are a few more which I will try to capture and share as well.

Take a close look at what is going on here. I didn’t record my voice during this but I recorded system volume this time, but you should immediately see what is happening and what I have tried to fix the issue.

https://1drv.ms/v/s!At5zujwlL9dBnNsYynPYVaTfu6CbWQ?e=QScMmE

(Note: I could have chopped up the video to show only the bugs, but I wanted to show my whole process, start to finish, so that you could try and figure out the triggers)


#12

Things to look for in the above video:

Issue 1: 3:05 (minor)
Notice that dinosaur (distant) is still lit.

Annoyance 1: this video shows how I am always struggling to squeeze out more volume. I waste so much time with that.

Issue 2: 7:01
I can’t move elements

Issue 3: 7:55
Sound doesn’t play at all now after creating a new mood, but then it did.

9:27 still can’t move elements

9:59 refreshed chrome

10:35: notice all the glowing elements

11:02 Notice that Test My Delete mode doesn’t even work anymore.

Refreshed again @ 12:00

13:00 opened a new Chrome instance and notice all the circles around the moods, most of which I never touched.

A complete unusable mess… it will be interesting if that mood will even be there later anymore.


#13

Thanks @dorpond

We’ll take a look at this on Monday!

It’ll be like a murder mystery investigation! :hocho::rabbit2:


#14

Did anyone on the team investigate this yet?