Updates - report SoundSets stuck in an always-needing-an-update state here


Hi All,

Is anyone else having the following issues, or is it just me.

In the SF (Desktop) Player:

  • I keep on downloading the RiseOf The Herald Soundset and when I start up Syrinscape again I need to download in again.

In the Fantasy (Desktop) Player:

  • I downloaded the 13/14 new Soundsets released at the start of August (2019) and now they all/most need updating. So I’ve run the update and they still need updating. I’ve run each Soundset through the update process at least 3 times, and still they need updating.

So, is it just me, or does @benjamin have a more serious issue on his hands?



Hi Dulux,
I’m having the same problem with DMM Level 1, 2, 3, 4, 5 and 6 along with FOP Mysterious Murder, GOS Sinister Secret I and GOS Sinister Secret II. It keeps indicating that there is an update and when I choose it to update it, it’ll run through the process but never update - it just reverts to “Install” again. I even tried to clear the soundset, reinstall and then re-update but pretty much the same issue. I’m not sure what’s going on…


Yeah, I’m not sure there really is anything that needs updating either…

…server getting a bit confused about what version YOU have and what version IT has.

This mainly: If you get told you need an update, and you update, you now have the latest version… ignore further suggestions to update for at least a few weeks.

in the meantime… this is a bug we are working on! :smiley::bug::crossed_swords:


Could it be something as simple as the version number in the manifest(s) is wrong, so that when the update happens instead of setting the version number to the correct (updated) one, its resetting back to the previous version number - I did that once; and assuming that’s how your updating system works.

On a different but related note - whatever happened to about that suggestion I made about putting in a filter to find all the uninstalled Soundsets - we’ve got filters for “All Soundsets”, “Installed”, “Purchased”, and “Unpurchased”, but as a Supersyrin Subscriber all the new releases are “purchased” and so I’ve got to scroll through the lists to find the new ones so I can install them. The system can tell me they are unistalled, so a filter sould be not trouble at all - surely! :slight_smile:


Yes… very possibly.

This is on the list of things to look at when we do a complete rebuild of the Fantasy Player. It’ll be interesting to see just what the problem is. AND how it arose from nowhere after having NOT been a problem for so long.


Hi, any update on a fix for this bug ? Because it is becoming annoying, there is actually 11 soundsets in the update section. Is it possible to uninstall them to get ride of that problem ?


This is NOT an incorrect version issue.
The set appears as if it was updated, but in reality some of the sounds were not downloaded and are not playing for me :frowning:


Waiting for the fix, I managed to erase the 9 folders, you can find them in c:/users/you/appdata/localow/syrinscape/syrinscape fantasy player/chapters.


Hi there. Is the bug killed ? Just to know if i can reupload the faulty folders. thanks.


Yeah… I simply just haven’t got to trying to fix this one yet. I suspect I might just need to trigger a fresh reprocess of the download file to sync up the version number correctly, but the general cavalcade of multitudinous tasks I get to attend to have prevented me from trying this yet… SORRY!

Might someone… put a fresh conclusive list of the exact SoundSets effected by this here, again… so I can use that when I get to this?!

THANKS! :slight_smile:


Hi Benjamin,
For those that show for me like that, I indicated them in the 2nd post of this thread. The 9 that show for me as needing updates (which don’t) are:
1). DMM Level 1
2). DMM Level 2
3). DMM Level 3
4). DMM Level 4
5). DMM Level 5
6). DMM Level 6
7). FOP Mysterious Murder
8). GOS Sinister Secret I
9). GOS Sinister Secret II



So it’s not just me! Nice to know I’m not crazy.


OK @daxdoomslayer I thiiiiiink these are fixed now.

You’ll be prompted to install these again from scratch and then they seem to stay in a “I don’t need an update” state for me now.

Working for you?


Seems to have worked for me.

So, what was the actual issue?


Yes, it is working for me too, thanks.


It looks like it is now working for me too! Yay!! Thanks Benjamin.


Looks like there was a mismatch between the time stamp and the actual processed Chapter-download file.

So I, changed the stub, to nix all previous chapter downloads completely and prepared a new download.

It was a bit of a hunch, but it worked, so i am not complaining! :slight_smile:

THANKS ALL, for your patience on this one!