Unable to download soundset made with creator in player


#1

Ok this problem has developed into something else entirely. I’ve gone over my soundset with a fine tooth comb and tried to remove every potentially problematic character from every element, mood, and otherwise that I can. So, unless I’m still missing it after 2 days of messing with this… then it might not be the old hyphen problem after all.

Basically, I can create soundsets… I can upload sound sets to the servers… I can see those soundsets on the website… but they aren’t listed in the player. And since they aren’t even listed in the player… they can’t be downloaded.

Here’s the JSON from the soundset export from creator. I have no idea what the problem might be.

Our next session is Sunday and I simply do not trust the creator to be reliable enough to use in an actual session. I will if I absolutely have to… but I’d really rather not.


#2

Bump… different problem than I thought. See above.


#3

It might got stuck on the server, but that is a rather easy fix. @Benjamin might give your sets a little push and they are out of the Goblin lair!

Edit: Hmmm, and what is the problem now? It seems like you can download them into the player. Doesn’t the download start when you hit the button? The size of the soundset is a little large with 105MB, but it could work…


#4

No. There is no download button cause the set isn’t listed. Look at the pictures. There are 6 sets in that campaign. Only 4 show up in the player. The “Elderith New World Inferno” sets are missing in the player.

I can download the other sets, but I don’t need the other sets… I need the New World Inferno set.

And before anyone asks, yeah, I tried looking in the “All” list… 4 elderith sets, New World Inferno is not among them.


#5

New wrinkle… when viewed under the Syrinscape Online UI the soundset has no elements and no moods:


#6

@JadedDragoon

I’m having a look at this now. Stay tuned.


#7

@JadedDragoon Is the Soundset maybe HUGE. More than 50 Elements?


#8

It was. I had read something about being over 100megs being bad so, right before the last screenshot, I had deleted it from the website and split the soundset into two different soundsets… a one at about 35 elements and the original now with only about 45 (a lot of overlap). The new soundset (35 elements) uploaded fine, the original one (45 elements) still does not.

I had never considered that 50 elements would be considered huge. I figured “huge” would be like 200 elements. One of my older sets has 63 elements. Considering that I’m working with sfx that I don’t have a lot of control over (due to low budget) I usually make up for the obviously repetitiveness or low quality by layering similar sounds together with asymmetrical timing to make it seem more organic.

A good example of that is actually in this sound set, which has an inferno made up of 2 identical groups of 6 elements, with 2 elements in each group being for closer fire noises and the rest being various different “distant” fire noises. There are two identical group so that (when 3d positioning is applied) I get an asymmetric and constantly changing arrangement of fire noises from multiple directions. Combined with my surround setup I use when we play it should create the impression they are caught within a forest fire (which is exactly what I’m planning to do to them come Sunday). Throw in the handfull of other SFX (combat noises, airship rotor noise, five one-shots each for spells of the allied and enemy caster) and it adds up in a hurry.

EDIT: Actually, if Syrinscape could play the same sample more that twice at one time I would probably only need the one of those groups… but I had to physically duplicate the sample files so that I had two sets of identical samples to make my elements from.


#9

Duplicated the soundset then tried to uploaded that… same problem.


#10

So, when a SoundSet uploads with no Moods or Elements. It usually means there is a problem in one of the Elements.

I’m having a look at the json, but it’s loooooooooooong! :smiley:


#11

yeaaah :-/ I really do appreciate it. I had sorta come to the same conclusion, but have no idea even what to look for.


#12

OK.

I think I have it:
Inferno_14595_1460041913 - Copy.transcoded.ogg
This file is broken or missing in the upload!


#13

Can you remove it from the SoundSet and delete it from your database and try another upload.

THEN.

Re-import a fixed version of the sample and upload again if you like!


#14

NOTE: Soooooon… Creator activity is going to all go online via the Syrinscape Online Interface… in which case we’ll all get much more feedback when we are uploading and there are errors.

Just one of the things we’ve been working on over the last 12 months! :slight_smile:


#15

looking forward to that! When you say “delete from the database” do you mean manually with an sqlite db editor? Or just from the list of samples in the creator interface?


#16

You should be able to find the sample in the sample search in the Creator interface and hit DELETE.

But the MAIN thing to do is remove the sample from any Playlists in which it appears.


#17

Am still getting the same error here:
Inferno_14595_1460041913 - Copy.transcoded.ogg

So it must be in a playlist somewhere?

In this Element:
Inferno Component (Blaze 1B

Delete that entirely?


#18

Yeah I noticed that a bunch of my samples were missing copyright text for some reason. (despite having already inserted it and double checked that it was saved). So the first few uploads were just fixing that.

However, once I deleted the sample things… escalated. At first it wouldn’t delete it. Clicked delete, warned me that it was in 2 other playlists. Went and deleted the sound sample duplicates. Click delete on the sample again again, still says it’s in 2 other playlists. Triple check and determine that its really not… click delete and then click yes i’m sure… Sample info panel closes… but the sample is still in the list. Click it again, click deleted again, click yes again… still there. Reload the creator ui in the browser (CTRL+F5)… and now… now I can no longer search for “inferno_” or “inferno” in the sample list. It just sits there and never refines the list.

Other searches work fine. Best guess? the entry for the supposedly deleted sample is now fouled up and that’s causing the search to fail when it hits that entry.

EDIT: yep, that seems to be the case, when I search for “inferno_14595” search fails. “inferno_14596” and “inferno_14597” work fine.


#19

Solved that problem by deleting the malformed entry in the database. Uploading the sounset with the suggested fixes now.


#20

Still fails.

Deleted the sample. Deleted the element. Deleted the sample file. Restarted creator for good measure. Imported the sample. Created element again. Added sample to it. Uploaded. And here we are.