Syrinscape ProTip #17 - MapTool URI Integration


#1

Hi everyone, I thought I would let everyone know that I have a fork of MapTool (@ http://maptool.nerps.net) that now supports Syrinscape’s 3rd party integration via URI!

I was going to wait until it was in the main branch but I figured everyone deserves Syrinscape integration! :wink:

To use it, just use the URI like any other URL in the source tag of hyperlink ( tags) or use the macro function like:

[h: sendURL(“syrinscape-fantasy:elements/YnVnYmVhci1iYXR0bGU6OjMtYmF0dGxlLWNyaWVz/play/”) ]

Some things I’ve done with it include:

o Automatically playing door open/close sounds when doors open via macro
o Playing custom “I’m ready!” or “Yes?” sounds on PC’s initiative. (NWN/Baldurs gate resources are awesome for this!).
o Created a frame with a list of buttons for the dozen “moods” I use a lot for quick access.
o Save various oneshots to macros on NPC’s ready to play for a given scene

Disclaimer: I do submit all the work I do to the main MapTool fork eventually but there can be quite a lag in time from creation to when it can get pulled in and built officially. So in between official releases, I publish all my work in my fork on GitHub @ https://github.com/JamzTheMan/maptool

PS Don’t forget to turn it on via the Preferences menu under Sounds.


#2

That’s Fantastic thanks @jamz!
I’ll have to check it out :smile:


#3

Hey jamz,

Thanks for sharing your contribution to Syrinscape Community.

It’s good to hear someone is still working on maptool and develops it. I tried to use your soft, but after download id simply doesn’t start (running exe installer for windows 64bit).


#4

Hey @Jamz, I’ve moved this to ProTips. Thanks again for taking the time to do it! It’s great to see the community doing things like this and making Syrinscape more accessible to other fantastic RPG products and programs :smiley:


#5

What version of Windows? I haven’t seen anyone have an issue running it really. There is no maptool folder in the start menu?

If it hangs, reboot and try again.


#6

Windows 10 64-bit. I just downloaded exe file from your website and once I double-click on it in Windows Explorer it hangs and nothing happens.

But, writing this I just remembered I had similar issue lately. It is Windows 10 problem. It does not show me message of the untrusted files downloaded from web. When I right-click file then Properties and check to unlock the file at the bottom, it starts.

Yet for MapTool itself I have some error window with:
“msg.info.configFeedback
msg.error.configBadFormat”

TokenTool is fine.
MapTool launcher shows the same Error, but after OK it shows window, but without replacing labels (just names of the controls in java msg.info.launchMapTool etc.)

Probably something with Java? Starting as Administrator changes nothing.

In fact it may be (?) related to the fact, that I have already installed original MapTool. And when I look now it shows the same message but starts maptool after OK :slight_smile:


#8

Ahh, yes. I should note, they install is not “signed” so windows will flag it as an untrusted source. Unblocking it allows it to install. FYI the “install” is just a JWrapper install which places Java JRE in your user directory and doesn’t affect any other java program that way.

Regarding the config error, I’ve only seen one other report a on rptools.net and is caused by the launcher not able to read your configuration file. Could be because your .maptool directory is somewhere with special rights? I would think running as admin would solve that.

Post over on rptools.net and we may be able to sort it out.