Syrinscape ProTip #07 - Using Syrinscape with Skype for Online Play


#21

I’m using Syrinscape with Fantasy Grounds and will also be using Skype. I have everything set per your guide (very clear by the way!) Now when I try to play sounds through Fantasy Grounds or through SyrinScape directly there is no sound. It appears to be playing in Syrinscape, there is just no sound. I am able to go on Skype and still talk to people, but they do not hear anything either. All sounds worked before adjusting all the inputs to integrate with Skype.


#22

Check out the FG Wiki Article on Using Syrinscape with Teamspeak - you can follow the same process to get Syrinescape working with Skype.

Let us know how you go, and we’ll see about getting you set up if you have trouble (BTW, there’s anew version of the DOESound coming out Soon™ which will alleviate the need to pump Syrinscape down Skype / TeamSpeak - but don’t wait, it’ll take a little while yet)

Cheers

Dulux-Oz
(DOE Sound Author)


#23

Just a reminder, ultimately we are headed toward a Master+Minion Syrinscape setup, where Player’s Syrinscape Minions are running on their local machines shadowing the GM/DM’s Master Player.

That way, no sound is having to go down any pipes at all. Phew! It’s gonna be GREAT! :slight_smile:


#24

Does this mean when the new version is completed that we will be unable to do it via other methods? I appreciate offering more options for people, but I (surprisingly) have players over 60, and they are not fond of having to install more things on their computer. They’re fine with the Fantasy Grounds - > Skype solution because all their laptops came preloaded with Skype and they use it to contact their children and grandchildren. All the work was on my end, and explaining to them to “just accept my call if you want to hear sounds”, was something they easily understood.

You have no idea how many hours it took me to help them get Fantasy Grounds downloaded, subscribed and installed on their systems (and in some cases, we have players who aren’t showing up because they’re embarrassed that they still can’t figure it out, and won’t talk to me). If I have to walk them through a Syrinscape setup as well, they’re going to stop wanting to use sound, which means I’ll stop using sound as well. (If none of the players are connecting to the sound call, why would I do the work?)

I think a parent/client setup for Syrinscape would be great - but I really hope it doesn’t break functionality for other solutions.


#25

Of course not @chris_lappe! :smile:

That’s great to hear you’ve managed to get it all set up working, especially with less computer literate players.

You’ll be able to still do that into the future and/or use the new options.


#26

No Chris, the new DOE: Sound v2 will not “break” any existing setup - you can still use it the way you use v1 now.

BUT it also offers a parent-child-type setup if you want, and you can mix and match and use both “modes” at the same time without issue - for some details check out the DOE: Sound Wiki Page on the FG Wiki (I got ahead of myself in posting the doco for the new v2 before we released it :smile: )

Cheers


#27

So this settup is not seeming to work for me, and I can not figure out why. SO maybe you guys can give some insight on this problem.

I have VoiceMeeter Input set as my Default Device, as well as having VoiceMeeter as my Output as the default device. This seems to works fine. So far.

In The VoiceMeeter Tray, I have my microphone set as “Hardware Input 1” (Logitech HD C615 Webcam), and nad sure that B is selected while A is off. However, everything falls apart at Hardware Input 2. I have multiple selections to choose from here, and none of them seem to work correctly.

I have WDM: Cable Output (VB - Audio Virtual Cable), which I believe is the one we are looking for, but when selecting that, I can hear nothing at all. The same result is found when MME: Cable Output (VB - Audio Virtual Cable). Then it gets even more complicated to me…cause I have the selections all over again, but the have (2 - VB Virtual Audio Cable) all of which return no sound.

I placed it upon VoiceMeeter Output (2 - VS Audio Virtual) just out of frustration, and I have sound, so thought maybe I was getting somewhere - My Realtek High Def Audio Speakers are on A1 for output.

I place VoiceMeeter Output as my microphone in Skype, as well as VoiceMeeter Input as my speakers (Cause none of the four options for “Cable Input” works, and this actually worked for the better part of two hours. A person I was testing with said they heard music and my voice with perfect clarity. When the rest of the group gets on Skype, and I try it out again…without changing any settings…it fails.

I’m convinced I downloaded something wrong (thus giving me four different type of Cable Inputs and Cable Outputs) But even still, I can not get the suggested format above to work properly. Any help would be appreciated.


#28

OK, so here’s how I’m set up:

I’ve got my Microphone linked into Voicemeter on IN1. I’ve got the VB-Audio Cable-Out set as the input to Voicemeeter on IN2. I’ve set the Voicemeeter IN3 as the default Windows Playback Device. I’ve got the Voicemeter OUT1 (A1) going to my Speakers. I’ve set Skype’s output to the VB-Audio Cable-In. I’ve got Skype to take its input from the Voicemeeter OUT2 (B).

Now, with this setup, I pump all three Voicemeter Inputs down the A-Output channel and Input 1 & 3 down the B-Output Channel. In the Audio settings of Skype uncheck the Automatic Adjust… on both the Microphone and the Speakers, and have both volumes set to max (this in in the Skype Audio Options page).

Thats it!

Incidently, this is exactly the same setup as is outlined in Case #1 of the Voicemeter Manual.

Let us know how you go.

Cheers


#29

Nah. It didn’t work. For some reason it works just find when in Skype with just one person, and one person only. After that. They can’t hear me talking when playing music…and they can’t even hear the music. So I dunno…


#30

I’m not sure if this has been noted anywhere else, but I have been trying to use Syrinscape on Roll20 for several days, and found the link for the Pro Tip #7…using it with Skype.

So I began playing around with voicemeeter and simply couldn’t get my skype or Discord to cooperate. The person I was trying to communicate with suggested we just log into Roll20 to see if our mics were still working…AND POW…everything was flowing in Roll20…I was able to use Syrinscape as well as another sound board I have purchased sounds for…they all went through Voicemeeter and came out in Roll20 for my players to hear.

So from my experience you only need to follow the first half of setting up Voicemeeter from that protip #7 link…you should be able to stop at the Skype section…worked for us at least.

Cheers,
Marcus


#31

Anyone figure this out for Zoom? I am using Syrinscape for streaming on OBS and while my broadcast hears it fine my players cannot. @benjamin, sounds like master+minion will be the answer. Will it be free for my players if I have SuperSyrin?


#32

Hi @tallsquall

A zoom setup should be quite similar to the other ones… just a matter of routing the right mix of audio to the zoom input (and selecting that input within zoom).

Anyone done this?


#33

Oh, and, not sure about pricing for the master/minion, but am currently leaning towards yes = free for SuperSyrins. :slight_smile:


#35

So I’ve set everything up as described above. It seems to work fine from my side, and my friends hear both my voice and Syrinscape on the far end. But whenever they say anything, the music cuts off.


#36

The Syrinscape Online Player is now ready for people to use.
(a few bugs still, but we are working through them).

Go here: www.syrinscape.com/online to find out more!


#37

So, I have followed all of the steps for VoiceMeeter listed above. I tested it with Syrinscape and hangouts, and the audio flowed through perfectly. The person I tested with could hear everything.

But, when I opened Fantasy Grounds, with the DOE extensions, and created links, they didn’t trigger the Syrinscape sounds. I feel like this is due to something I did (or didn’t do) in the FG end, and not Syrinscape, but any help would be appreciated! And, to confirm, I have both the DOE base extension and Sound extension running.


#38

First of all, as has been noted elsewhere, the current version of Syrinscape (v1.3.7) does not work with the DOE:Sound, you need to use the previous version (v1.3.3). Secondly, have you turned On Sounds in the Fantasy Grounds Options?

These two things account for over 90% of all errors (lately) :smile:


#40

This walk through worked for me perfectly, the only thing I had to do differently on Windows 10 was make sure that on the playback and recording tabs that the Default Communication Device was the same device that your guide said needed to be the Default Device. When I first got it working my testers could hear themselves because on one of the tabs the cable had been selected as the communication device. With them set to the same thing, this issue went away.


#41

Hey there. First of all I love this idea and hope to get it to work. What I am having issues with:

  1. I have Hardware input 1 on my MIC with only B1 selected… I have no option for ‘cable’ on hardware input 2, and not matter which selection I use, my players are getting a small echo from themselves.

  2. In Discord, is it possible to get the Syrinscape to play constantly without disabling push to talk? I would like the music or sounds to be continuous but not have my mic wide open.

Thanks!
Mike