Syrinscape Online: Upload error "undefined 0 error" or "404 Bad Gateway" - RESOLVED


#1

I’ve been attempting to upload sounds to Syrinscape online, but I’m always getting returns of error 0, undefined, or 404 Bad Gateway. It’s even happening with sounds I’ve already uploaded fine before. But now it’s not working for some reason. I’ve tried switching servers, but that doesn’t change the outcome.

https://gyazo.com/92dba7c9929e1e9bd2e3b110e44a74dc

I’m stumped and confused.


#2

@tfarrington3d I’ve been unable to find the sample you are trying to upload, nor reproduce the error with other samples. Can you DM me a copy of the sample you are trying to upload so I can test with that?


#3

Done! I’ve DMed you an audio sample I’ve tried to upload and it too has failed. It’s pretty much with any audio sample I try to upload, it gives me the error message, which is annoying, as this hinders my ability to make custom soundscapes of any kind.


#4

@tfarrington3d I haven’t been able to replicate the problem with your sample, but I did locate some detailed error reports. I’ve bumped this up on our todo list for closer investigation.


#5

@tfarrington3d We are still unable to reproduce this issue locally or on production.

From our research, one suggestion was that it could be caused by an ad blocker. If you are using one, could you try to disable it? Also, try a different browser, or a different computer on the same network?

Could you also confirm for me which domain is in the address bar of your browser (www.syrinscape.com, or syrinscape.com), and which domain is being requested when you try to upload (by opening Chrome or Firefox dev tools and watching the network tab).

Here’s a screenshot to demonstrate:


#6

I can indeed confirm that it’s from www.syrinscape.com, not syrinscape.com.

https://gyazo.com/30954f2138c00a312f2cf9814c585250

Oddly enough, in attempting to upload to Chrome instead of firefox, the bar just stays stuck at 100% without having uploaded anything.


#7

Update: I’m now getting this error:
https://gyazo.com/4e465a7fa3d8092bec0d46ec0ec22284

Telling me to check my connection and disable any browser extensions. I’ve disabled all my browser plugins and disabled my VPN, checked my connection and it’s fine, but the upload still stays locked at 100%, without any upload actually going through. Happening on both Firefox and Chrome.


#8

I’m unable to upload pretty much anything at this point, which is frustrating to no end.

I use this service so I can make custom soundscapes with my own content, but now I can’t do that anymore.

I’m at the end of my tether here and I don’t know what to do.


#9

Update: it seems as though, while uploading .wav files didn’t seem to work, uploading /mp3 files and waiting for the transcoding to finish seems to work, which is strange. I’d always thought you had to upload specififically as .wav files to have them work.


#10

That used to be the case. They had an update a few months ago that allowed mp3s to also be a viable upload option. I haven’t uploaded anything recently but it’s weird that wav files aren’t working. Have you made a support ticket also? The syrinscape gang are able to respond faster to emails then the forum posts.


#11

This was one of the really good things with things happening directly on our server now! We are not dependant on whatever random codecs are actually working on people’s machines… so there are actually LOTs of formats you can use now!


#12

@tfarrington3d that updated error message is a change we recently deployed to provide additional context to users and a hint about what might be causing a problem.

We have been unable to reproduce the error, even with the files you have provided, on a number of browsers and operating systems. You should be able to successfully upload any WAV, MP3, OGG or FLAC file up to 100MB in size.

Are you able to test with:

  • A different computer on the same network?
  • A different account on the same computer? (user account and/or Syrinscape account)
  • A different network (work, school, friend’s house)?

I believe the specific error you are seeing occurs when the browser refuses to even establish a connection for some reason. It seems odd that would be the case only for WAV files and not MP3.

One suggestion has been CORS (cross origin resource sharing) policy blocking the browser from making a connection from a page loaded on one domain to another resource on a different domain, hence my question about the domains being accessed in the network tab. We have had trouble in the past with cache data including links to a previously used server after reconnecting to a new server. That should no longer be an issue, but I have just cleared our cache for your account anyway to be sure.