Syrinscape/Fantasy Grounds Integration issue


#1

Hey, guys. So I wanted to reach out on an issue that I am constantly having now when I run Syrinscape with Fantasy Grounds and the Dulux-Oz’s DOE: Sound extension. So, to set the stage, I use the DOE Sound extension and a library of automated chatsounds to trigger syrinscape (and other program sounds) automatically based on chat strings or manually triggering from within Fantasy Grounds. Whenever I start my game things run great at the beginning. However, at varying times, sometimes an hour into a session and sometimes three, the chatsounds do some strange things. They do any of the following 1) stop triggering altogether or 2) trigger inappropriate sounds (such as unconscious when there is no reason to play the sound). Its almost like its playing sounds from 5-10 minutes ago.

Some more detail. When I start having the sound problems and I try to click on the sound links within fantasy grounds to call the url and play the sound from the Syrinscape player, nothing happens. That is how I know I’m having issues. However, if I go to the Syrinscape player itself and trigger the sound, it triggers just fine. Also, importantly, when these issues begin happening, the triggers I have for other sound programs (ie. url links in Fantasy Grounds to youtube or to vlc or groove music to play sounds from my hard drive or the internet) still trigger just fine within fantasy grounds when I click on them. So, I don’t think it is an issue with the DOE Sound extension.

Finally, I downloaded a program today called cleanmem. Now I don’t want to get into a debate on whether or not it is useful and helps with memory leakage, but I wanted to monitor my RAM usage at a glance. So, I booted Syrinscape, Fantasy Grounds and all the usual programs I run for my game and started playing with sounds for a while. Sure enough after 30-40 minutes I started seeing the issues pop up. However, I looked at my RAM usage and it was minimal and didn’t spike at all. I also did the control alt delete thing and and looked at my overall memory usage and cpu usage and it was minor. No capacity issues there.

Anyway, I realize this is a very specific use case issue but I love using the two programs together and I’m struggling now to keep my games going seamlessly when these issues crop up every time I play. One final note. I’ve tried reloading fantasy grounds and other steps when this happens and it doesn’t resolve the sound issues. What does resolve it, without fail, is rebooting the Syrinscape player. If I shut down the fantasy player and relaunch it, everything works fine again for a while. I do use voicemeeter banana, but I don’t see how that should affect anything as that just routes the sounds to the proper outputs.

Any help/thoughts are greatly appreciated! I love both Syrinscape and Fantasy Grounds and would love to get these two to operate more consistently together. Would love to hear if anyone else experiences the same issues.


#2

So, I did find another topic that is similar to my issue. It was entitled, “3rd Party Integration Stops Working”. The poster seemed to indicate his just resolved. However, Ben did ask the following questions in the thread:

  1. So if you run one of the URIs in the run dialog in WIN+R what happens?
  2. What virus/malware stuff are you running?
  3. Run Syrinscape in Admin mode?

So, I thought I would answer them here to give more info.

1 - Well, when things are running as normal and I try this, the appropriate sound plays from syrinscape. However, once I start having the sound issues when I try this it either plays no sound or it literally plays a sound different than the URI I input. Don’t know how that is possible but I swear it is what happens!

2 - I am running Kaspersky Internet Security. Usually acts just fine. I have syrinscape whitelisted but I don’t know if there might be some “listening” program ben referred to that could be flagged in Kaspersky or not. Weird that it would work fine for a while and restarting Syrinscape fixes things for a while though.

3 - I’ll have to try this I guess. I normally just launch syrinscape. I know the poster in the other thread tried to run as admin and it didn’t seem to help him.

If you have any thoughts on this, please let me know as it has slowly driven me mad over the last several months… :smile:


#3

It sounds like a memory leak issue, and because it clears up when you re-launch Syrinscape I suspect the issue is in Syrinscape, and in particular the 3rd Party Integration area.

I know how you’re running things, and you’d have to be the most heavy user of the 3PI (via the DOE: Sound) around. This is why I suspect the issue is inside the 3PI code.

I’m wondering is Syrinscape is 32-bit or 64-, and if that is the issue. For example, you might be overloading Syrinscape’s “internal buffer” with all the 3PI calls, but if the “buffer” was pre-loaded/allocated then there would be nothing extra to show in a memory monitor.

However, this is all just (educated) speculation because I don’t have the source code for Syrinscape. But this may give Ben a few ideas where to look - even if its just to prove me wrong because I’m full of :hankey:

Cheers :smile:


#4

Thanks, Dulux_Oz. Anxious to hear if Ben has any additional ideas or possible fixes. Honestly it wouldn’t be a big deal to just shut down and re-launch syrinscape in most cases. However, because I stream live and use voicemeeter banana, when I shut down I can’t just relaunch it. I have to change my sound settings to Cable B input, re-launch syrinscape and then switch it back to voicemeeter input. Once I do that I then need to check and make sure discord still recognizes my microphone as discord (in my experience) has challenges sometimes when you switch sound inputs while you have it open. Then if discord doesn’t still recognize my microphone I have to completely reboot my entire system! With Fantasy Grounds, voicemeeter banana, syrinscape, OBS broadcasting software and several other programs up that is a serious pain mid-live stream! :smile: So, what I tend to do when the sounds start to go wonky right in the middle of my stream is just shut them down which stinks.

So, it is a pretty simple fix for most folks, but unfortunately requires several steps on my end to fix it mid-game with the possibility of having to reboot everything. I totally understand if this is just a fringe case that doesn’t affect many other folks and can’t be fixed at this time. If that ends up being the case, I just need to figure out a better workaround on my end. Thanks!


#5

Hi @Gwydion,

The actual plan is to move the whole thing over to Master/Minion.

We are ensuring that the same kind of 3rd party integration thing will work through Fantasy Grounds. We will involve @Dulux_Oz to make sure this happens smoothly (when we are ready).

Sooooo… give us a couple of months and we’ll have it fixed for you.

And THANK YOU for your patience… in the meantime… :slight_smile:

Can I offer a :rice_cracker:?


#6

Offer accepted… :smile: You can send the cracker to the following address:

…jk

I’m working on a few things that might be an interim solution for me… I have ideas! Thanks, Ben.


#7

Well… I tried a boatload of things as a workaround but none worked so far. Is there any way to do any kind of “cache reset” in the syrinscape player without shutting the player down completely? I’ve tried things like the “reload” button on the player and even preloading a number of the soundsets before I begin a session, but none if it helped. I will definitely try and be patient, just trying to see if there is any workaround that will help me in the meantime! Thanks, Ben.


#8

Ok. I think I learned something and can use this as a workaround for now. Every time I go to launch Syrinscape, I change BOTH my default Recording and Playback audio device to Cable B (input/output). However, I think I only really need to change the Playback audio device before I launch Syrinscape. I’ve tested that and when I close Syrinscape with Discord launched and then switch my Playback only to Cable B input (and leave Recording to Voicemeeter Output), Discord seems to still recognize my mic just fine.

I think all this time when I’ve been changing the default Recording and Playback before launching Syrinscape I was causing myself issues. Now when the links stop working in Fantasy Grounds I think I can close and reopen Syrinscape and keep my stream going without interrupting my discord setttings.

Fingers crossed and I will try this next stream!


#9

Just to close this out… I ran a one-shot last night on Christmas. Syrinscape did stop working three separate times for me but I was able to close Syrinscape and only change the Playback audio default in windows to Cable B and restart Syrinscape and the issue was fixed! Unfortunately I had to do this three times, but the good news is it worked just fine and with little disruption for the players. Yeah!!


#10

OK. This is good to hear. Thanks for the feedback!

Once we get the Master/Minion 3rd party integration working we should be able to make these issues go away properly, but I’m glad its working at some usable level at least now.


#11

That will be great–to do 3rd party integration via Syrinscape Online. The ultimate solution!