Syrinscape and Teamspeak 3 = Warbled Sound...Fixed!


#1

New subscriber
Windows 10
DM wanting immersive sounds for my players during our Roll20 sessions.

I configured the virtual cable to broadcast the Syrinscape sounds via Teamspeak 3 but the sounds come through all warbled like you’re hearing it underwater. Wavy, garbled.

For the “DM Sounds” Identity in TeamSpeak:
I set the capture to the virtual cable, continuous transmission.
On connect Playback is “none”

I thought maybe it was my onboard crummy Realtek sound, but I just installed a new sound card this morning and the results are identical.

Are there other settings I should be aware of? Should I give up on TeamSpeak for the sounds and try Discord instead? What other options can I try?


#2

I’ve not used Teamspeak myself but I know others have. Have you followed the instruction here? @Dulux_Oz & @Gwydion normally have some great answers and advice for voip systems :smile:


#3

Thanks for the reply Steve.

Yes actually those are the instructions I followed, and it is working but the quality of the audio that users hear in the channel is just horrible despite the fact that I have the settings for that channel in TS set to Opus Voice with a quality of 10.

Is there a trick to setting the output in Syrinscape? Is warbled and in a fishbowl the best that can be expected from this method through Teamspeak…and if so what other options should I explore for my players to be able to hear the awesomeness that is Syrinscape online during our sessions? We use Roll20…so as I understand it integration with them isn’t available.

Any all suggestions and assistance is greatly appreciated!


#4

Sorry for jumping in this late. Typically teamspeak sound quality (for me) is better than discord and shouldn’t be warbled. Could be any number of reasons! If you’re interested I can message you an invite to my discord server so I can have you post some screenshots of your setup to see if I can see any issues with it. Let me know and I’m happy to try and help if I can.


#5

Thank you so much for the reply @Gwydion. I’m super relieved to hear that its likely some settings somewhere that need to be adjusted properly. Your offer of help I will most definitely take you up on…incredibly gracious of you to offer. Again greatly appreciated. Let me know what screenshots I need to take and in what format you would prefer them in and I’ll endeavor to get those over to you.


#6

Hey! Here is an invite to my discord channel. https://discord.gg/ZbjZnh8

I’m not available tonight, but if you join my channel I’ll message you in the morning of the screenshots that I’d like to look at and we will get it sorted! Have a great night.


#7

Hey, Embercraft. Just checking back in. If you join my discord channel it will be easy to exchange pm’s there. The link above should still be active. The screenshots I’ll want to see will include the following:

Voicemeeter settings (if you are using voicemeeter)
Teamspeak capture and playback settings for the profiles you have set up
Windows default sound playback and recording settings

Thanks!


#8

Hey Gwydion,

I joined …yesterday I think? This week, until just this morning, has been a total bear with work so this is the first opportunity I’ve had to be able to respond. Apologies for the unintended blank space! I’ll get those screenshots over to you in a PM in Discord. Thank you again for your offer of assistance, I think we can figure this out!


#9

UPDATE

@Gwydion, put simply, ROCKS.
So here is what I learned. I had set the channel audio in Teamspeak to Opus Voice and the quality to 10…thinking more is better. In reality I was trying to push too much quality through and it just couldn’t handle that amount of bandwidth. Setting the Channel’s Audio Codec to Opus Music and dialing back the quality to 6 did the trick. Syrinscape sounds as beautiful as it should and my players are going to be over the moon about the new sense dimension.

Thank you @Gwydion for your diligence and perseverance in getting all of this sorted for us. Your help and guidance is absolutely stellar …really don’t have the words to adequately express my gratitude.

Almost forgot! We did make one other adjustment that could have an affect on the outcome as well…and that was to sync up the output sample rate for all devices involved so that they all match. So Virtual Cable and its Control Panel both set to 48000 Hz. Doing this alone didn’t change anything but it may affect the outcome to some degree regardless. So Sync output Hz rates and set TS Channel Audio to Opus Music Codec, Quality < = 6.

Cheers!


#10

Awesome! Glad you got it sorted and a massive thanks to @Gwydion for all of your help. You guys really are the best :smile:


#11

Too bad there’s no real documentation for TS3, or we might understand what “Channel Audio” is and where to set it.

  • s.west

#12

All right. So I found a Teamspeak page with a “How to” for setting the Channel audio codec. But that still doesn’t excuse them for not producing a genuine user manual…
Just sayin’

  • s.west