Super loud sounds in Online Player


#1

When switching between soundsets in the Online Master interface - i.e., choosing a Mood in a new soundset (whether one has stopped all previous moods or not seems to make no different - the volume of the newly selected mood is extremely loud, often much louder of than any other sound source played before it. I’m not 100% sure but it looks like sometimes the system decides to maximise the volume of everything: all the individual elements, and the Master’s level, and possible the Minion’s level as well.

My ears are still ringing!

I ran into this bug earlier this evening, though it happened just with a campfire sound, which was unpleasant but not painful. However, just before now I played “Weiralai Battle” in the “TTT Under Iris Hill” soundset, and it was pretty painful on the ears (had to get my headphones off fast).


#2

Wow! That sounds bad. :-/

I’ve never experienced anything like that.

Can you give me a reproducible set of steps to make this happen and I’ll try myself… though with the volume not high!


#3

To the best of my memory, I had flicked through moods from maybe five or six soundsets prior to “TTT Under Iris Hill”. I had the master level in the Master interface set at 65%, and my Minion player at the default 50%. My local volume levels were comfortable for listening - streaming TV, music videos on YouTube, etc. Browser was Chrome. Windows 10 Home.

I’ve had the “maxed volume on mood change” thing before, I think, though with less diastrous total levels. I think the “Weiralai Battle” mood maybe just stacks a lot of very loud samples when it starts, which the maximisation then compounds? Without knowing about how Syrinscape does its internal Gain Staging I can’t know exactly how the volume got so loud.

But in short, if I wanted to reproduce this effect in Cubase, I could feed full-spectrum noise (or whatever other sample) through multiple buses, maxing out the +gain until my master bus was just maxing out constantly.

EDIT: I’ve noticed that the levels of the samples Syrinscape uses is very variable, and that some soundsets seem to use the gain trim on their elements as a means of lowering the very high volume of these samples. That would explain why, if sometimes the Online Master fails to read the “initial volume” of an element, and has it play at max volume, one could find things getting very loud very fast - c.f., my thought above about whether offending Mood in this case stacks a lot of samples which are very loud in their raw sample files.


#4

I’ll have a play with those SoundSets, but I guess if you happen to find a way of making it happen repeatedly that always helps debugging hugely!

Sorry about your ears!!! :frowning:


#5

Just trigger the “Weiralai Battle” mood in “TTT Under Iris Hill.” Even when it’s working as designed, the creature-cry-sounding effects are pretty intense and shimmery.

To simulate the effect of what I expereinced, start the mood going, then manually drag the volume sliders of everything to max. And then hit “Roars (Werelai)”, which triggers at the start of the mood.

EDIT: I generally get the “everything maximises” bug once in anywhere from a dozen to two dozen mood changes. It just happens randomly when changing moods.

EDIT 2: When one changes to a new mood, you can actually see the volume level sliders animating down from Max. Which seems to me to indicate that the system actually initialises with the volumes at max, and then runs a bit of code to pull them down. That’s not great. The sliders default value should be zero, if there are high-volume samples around, and the initial volume settings should be pulled up to from there. IMO.


#6

OK. That’s good info.

Having a play now. :slight_smile:


#7

Sooooo… I don’t think we are looking at an Online Player bug… just a mixing choice by the person who made the set.

Do you experience the same thing in the actual Standalone Player, right?

Elements can have ‘initial volume’ settings and these elements are all set to 100% when they load up.

Though… I think it is really just that that SoundSet is super aggressive and loud>

There is a master volume per SoundSet which I could set lower (for this one).

I’ll have a look.


#8

Actually…

I think some of the 3D positioning maybe different in the current build of the Online Player!

Sounds that are set further away in the mix are actually coming out right at the listener… that would definitely make them louder.

OK… Stay tuned…

Digging deeper!


#9

Thanks for looking into this. I would rather have a reliable fix than not use Syrinscape anymore. Great software. :slight_smile:

I am definitely getting an intermittent bug though where the level of an element doesn’t get adjusted (i.e., gets left stuck at max) on switching to a mood. One can tell because, for example, the slider will say “50%”, but adjusting it to “60%” will make the volume of that element drop.

Also, having now tested in the local Fantasy Player, the soundset is a lot less aggressive in there.


#10

Forgive the threadjack, but Ben: did you ever look at the online player volume problem I reported back in June? I posted in the Public Beta category, but I believe you were off jet-setting at the time…


#11

@Modal I have always gotten that bug. Whenever I switch moods they are always at 100% no matter what the slider says. I usually quickly toggle it on then off, then on again. The second time i toggle it on the max volume matches the sliders.


#12

OK. We are onto this one now. :slight_smile:

The Online Player is going to get a LOT of love over the next couple of months.

Expect it to be AMAZING! :blush: