Soundset Creator - Download Failed - RESOLVED


I’ve been getting this all day. When I’m in the soundset creator and try and download a new soundset I’m getting a message telling me the download failed and I should try again, so I do… alot. Eventually, it’ll work but around 80% of the time I’ll get the error and it’s happening a various stages. Sometimes during the actual download or sometimes while it’s on the “queuing” stage.

Any ideas?

I’m actually having the exact same issue. I only started using creator a few days ago but it’s giving me the same error.

Yep I’ve noticed the same error over this weekend. Doesn’t happen all of the time but enough to be noticable. It looks like it’s due to server traffic, with Gen Con at the weekend our servers have been VERY busy. But we are keeping an eye on it and trying to make sure we can put a stop to it

Dang people having a good time over there at the thing I couldn’t attend this year… shakes cranky old man fist

1 Like

Yeah, sadly pretty unusable tonight. I can download like one soundset every 5-10 minutes

I understand the issues with server load but is there any update on this being resolved soon? I’ve not been able to download a single soundset since my initial post. I even went so far as to try it as 7am (UK) time this morning.

I have a game coming up! Help!


Resolved on another thread, see HERE for more details :slight_smile: