Sound plays fine in creator, doesn't play on Sci-fi player


#1

I have a sound set (Torg Eternity - Day 1 - Nile Empire) that I created that has an element with a sound (marching) that appears throughout it. It is a custom sound I uploaded, and it works just fine when I test it in the creator. When I load it up in the player (this one is in the Sci-fi Player), it is silent. The other sounds that start with it (also custom sounds, same format) work fine. I go back to the creator again, and it works just fine.

The odd thing is, when I hit the ‘stop’ button, I hear the marching sound for about a second as it is stopping, and it sounds like it is doubled.

I’ve cleared all of the soundset data and reinstalled the sound set several times, and it doesn’t make any difference. I’ve tried making minor changes in the creator to cause it to save again, then redownloaded it, and it doesn’t make any difference. I’m not sure what to try next.


#2

Oh, and an extra point: When in the player, the arrow lights up that it’s active, and the circle around it is solid, but doesn’t move.


#3

Hi @jtw321

I had a good fish around for a problem here, and I think I’ve got it fixed.

Looks like the Marching Element was set to both:
Crossfade
AND
Count delay from sample start

It was dying trying to play an infinite number of samples at once! :space_invader: :whale:

Working for you now?!?!


#4

Sorry, took me a while to fiddle with it. Yes, that solved it, and thank you. I honestly don’t know why count delay from sample start would have been checked. It wouldn’t be at all useful to this element.


#5

I blame ACTUAL Goblins! :space_invader: :crossed_swords: