SCI_FI Player Not loading

I’ve been using the Fantasy Player for a few years now on my PC. Now I going to run a Sci-Fi game so I downloaded the player. When it launches it stays on a page with a background image and just sits there.

The Fantasy player will launch and work fine.

WIN 10.

Any suggestions?


1 Like

This morning I disabled my firewall and downloaded the boardgame player. Fantasy player works fine, however SC-FI and Boardgame do not load.

Ok another one. Same with the board game.

I installed them on another account on my desktop and they both worked flawlessly.

So any ideas on what may be interfering with my user account?

One further update.

I downloaded [1.4.13-p0] and it is working. Hope that helps. I am willing to help debug it on my machine id you need anything.


Hi @ergoironfist,

What about if you NOW install the latest version of the Sci-fi player over the top of the old. Does that work now?

I presume you’ve tried letting the Sci-fi player sit on the startup screen for a while and shut it down and restarted.

Also, have what about if you run the Sci-fi player on something completely different with your account… does that start up normally?

Note: there IS a chunk of things these players do on FIRST start… so you should expect a bit of a rest time on that startup graphic… but I presume you gave it quite a while!

I’ll continue to think. :slight_smile: :robot: :hammer:

Yep I let it sit overnight and nothing. I’ll the the new one now. Do I just install it over the older one?

I did run it on another account on my computer and it worked there.

Yes, just install it right over the top. :slight_smile:

Does your account on your computer have any non boring ascii characters in the name? As in, é, ü, etc

Nope. And Like I said it worked on another account on the same machine, I’m thinking some installed software is causing the issue.

1 Like