Sample normalization (or change default slider position)


#1

Music “samples” can be particularly problematic because of varying sound levels. It would ne nice if the system normalized samples so that some songs aren’t very quiet while others come in very loud.

This probably involves a bit of coding work. So a better solution might be to just change the default slider positions:

It’s currently possible to do this manually by turning down the default volume of loud samples, but sometimes, if there are many louder samples and just a couple of softer ones, you have to go in and turn ALL the samples down and then go back and turn the quieter ones up.

If the default setting for samples within music elements were to be, say 80% of maximum volume (instead of 100%), it would allow a single sample to be amplified relative to the others and make it easier to at least manually normalize the element.


#2

With music make sure you set the element type as “music” and ensure you that you have turned off the 3D positioning. The Creator is already set to deal with music separately to other elements, you just need to make sure you have it set to the correct setting


#3

Thanks for the response, Steve!

I do that (both set the element to “music” and positioning to disabled) but I still notice a significant difference in the volume between a couple of songs.


#4

Have you deactivated the 3D positioning at sample level, too? When uploading a sample and you put the credentials in, there is a box you have to untick to deactivate the 3D positioning capabilities.


#5

How are you going with this one?


#6

"difference in the commune between " wow I missed that autocorrect fail didn’t I?

I went back and looked and a number of tracks did indeed have 3d positioning enabled… on probably 2/3rds of the songs. This is really weird because I know I unchecked that selection initial implementation. Obviously that’s not what actually happened so I’m clearly going mad. /shrug sorry for the bugaboo.


#7

I have found that if I uncheck it at the sample info where the CC goes it doesn’t effect the element that I put it into and I still have to uncheck it on the element.