Question on Volumes keep resetting?

Hi there, have searched for an answer on this but couldn’t see anything.

In the pic, whenever I reload my soundset after a few days, the volumes for each element shoot back up to 100%? I like to keep these around the 50-60% mark as I have greater control… any suggestions why this keeps happening?

Also, it possible to colour code and/or change the default music icon on each sound? Would love to group by colour or graphic so can quickly and easily find what I want. Cheers!

This annoying feature or bug happened to me as well.
I was creating oneshot spells and adjusted each one’s volume in their respective Soundsets (Cleric Spells, Wizard Spells, etc). But after a few days they all adjusted back to 100% (which plays too loud in comparison to the other sounds.

So I copied all the spell sounds into a custom soundset, renamed, organized, and set the volumes… And again they went back to 100%.

I currently have the soundset as a whole set to 50%, and that basically works, but it should not be resetting.

Thanks for this… anyone else can maybe add something please?

Also, is it possible to customise the tokens?!

BUMP! :slight_smile:

Bump! Can anyone help me please?!!

Sorry, yes, I’ve been seeing this thread and thinking about it. I’ll chat to @sonofconan (lead dev) about it tomorrow. I need his help to nut out exactly what might be happening here. Though I have a couple of ideas for work arounds.

Note: if you are needing a timely response, then the support email will get you a quicker response.

HI Benjamin, any updates on this chap?
Also, part 2 of question, can we colour code the SS buttons at all?!

I’ve bumped @sonofconan to take a look.

Question from me:

  1. are you setting an initial volume in the element, and that is being disobeyed?

@craig.perry @DrWiFi please take note of the current server you are connected to. E.g. s10 in this screenshot:

Then, if the problem happens again, check if the server has changed and let me know. It is possible that some state is lost when transferring to a new server, or perhaps when we restart the servers after deploying an update.

If you can confirm that the problem occurs with a server change, that could help us track it down.

1 Like

Hey. No I don’t think so, simply using the slider on the main page. I drop it, then when I come back a few days later, the slider is back at the top…

@sonofconan - noted and will keep an eye out.

Do note: this was never the real intention of how elements would work. Elements are there to be set to a volume (and started and stoped) by MOODs.

Each time a user starts up the Fantasy Player, all Elements will initialise at thier Initial Volume (under the element inspector).

Elements retaining the setting they may have been set to at other times by the user was something that sort of became possible with the new architecture of the Online Player = BUT it is not something we have concentrated on much, because that is not the way WE use it or think about it.

TRY THIS FOR ME: set the volume you want as an Initial Volume in the Element inspector and see if (upon the next random update) the volume get initiated to THAT volume, rather than 100% (which is probably what the Initial Volume is set to at the moment).

Makes sense? :slight_smile:

Sure does! Thanks for taking the time. Will be playing tonight, so will see what happens and let you know. Cheers.

PS. What about colour coding the elements?! I want a rainbow warriors mood board at my fingertips lol :wink:

HI there, bad news I’m afraid… spent some time yesterday changing all initial volumes to the desired level, around 50%. Came back today and they’re all back up at 100%! Also in the element properties too…

Edit: MOST of them are back at 100%, some are at other levels, but definitely not at the level I set them too…

@sonofconan - I did make a note of the server number though and it HAS changed. I was definitely on s11 yesterday, but today, it now reads s1.

Hope that helps!

I have the same concern. I made extensive adjustments to many music elements in the Element Inspector, but everything’s popped back to 100%. I often want elements as background music for fights, along with my choices for sword hits, etc. At full volume they just cover up the elements I want featured. I use mattekure’s extensions and mods to imbed links in my Fantasy Grounds story pages, so adjusting on the fly isn’t an option. It would be great to find a way to make the changes stick.

Bumpity! Any update for us guys?!

Nothing to report here.

We have the info on this thread, and the bug is ticketed up to look at, but there are a number of things above this on the list of things to do. We will get to this, but not this week.

Either way, thanks for bumping… when people jump on and +1, it helps us to tweak priorities and this one just went up a notch. :slight_smile:

@craig.perry, here’s my workaround. I created a campaign called “My Battle Music”. Made a copy of the mood I wanted (Saltmarsh Fight), set the volumes as I wanted, and then renamed it zzzSaltmarsh Fight. Repeat with the other moods I want. My volume changes persisted. The zzz prefix makes them easier to find when I import them into Fantasy Grounds.


This issue is definitely getting a frustrating. Here’s a real example of the negative impact this bug is having.

<< I begin setting the mood for my players >>

“As you eat your meal you can see hints of the sun setting through the nearby window. By the time you’ve finished your meal at this deserted tavern, your eyes and body feel heavy. You hear a faint rumble of thunder as light rain begins to fall…”

<< I go to my rain element, turn the volume down to 10% and hit play. >>

<< Rain begins and snaps to 100%, sounding like a torrential downpour, ruining the calm atmosphere I created. >>

<< We all laugh at the situation as I lower the volume again. >>

That moment is ruined. I really hope this bug is fixed soon.

I love Syrinscape so much and honestly can’t imagine DM’ing games without it anymore. I appreciate all of the Syrinscape Team’s hard work.

hey @dm_dan,

That’s pretty annoying!

While this is still in the queue to get fixed, wanna try another work around for me?

Go to the playlist of the element that is too loud and set the max and min values in the sample entry to a MUCH lower volume. I’m 98% sure those values won’t get reset.

Let me know how you go. :slight_smile:

1 Like