Online Player Problem - Game Master Can't Hear Moods - RESOLVED

I have a strange problem - I don’t know if this has been reported.

After I’ve used Syrinscape for a session, the next time I open the Master Interface and run Syrinscape Online, I am unable to hear anything that I played during the last session. Minions can apparently hear - but I as the GM can’t.

For example - last session I played several of the Rime of The Frostmaiden Termalaine as my players explored the town and the Gem Mine. When I restarted the app today to set up for the next session, I tried to play these moods and can hear nothing. I logged in from a laptop as a Minion, and can hear just fine.

Viewing the Master Interface, I can see that the elements are playing, I can hear them logged in on a different computer as a Minion, but can hear nothing at all as the GM.

I have also noticed that the Online Player attempts to start whatever sounds I was playing when I closed the program last - though I can’t hear it.

Any mood or sound that I did NOT play the previous session works fine.

Reinstalling the program restores normal function.



When a PLAYER joins into a game, in case they’ve missed a button click from the GM who might have already started sound for themselves and for the other players, they get trigger to play whatever MOOD the GM last clicked. NOTE: there sounds might be out of sync until the GM actually trigger something completely fresh.

This does NOT work for the GM, because YOU are the one triggering the sounds can can do that for yourself.

This MAY be creating a weird effect for you?

Have you tried simply hitting STOP and letting everything totally wind down, and then starting a mood again?


I have - and it happened again, tonight.

Here’s the process exactly, from a clean install (having uninstalled previously, and re-activated my computer).

  1. Have a session, everything works great.
  2. Close both Syrinscape Online Player and the browser running the Master Control, in this case, Microsoft Edge Chromium.
  3. Reopen player for next session, log into Master Control, and begin playing a mood from the previous session. My players can hear everything just fine. I can’t hear those moods at all. I can hear moods that I did not play in the previous session. If I don’t reinstall at this point, the moods I played in a second session are unable to be heard in a subsequent session.
  4. Reinstall, everything works fine. Rinse, Repeat.

This all began when the Online Player prompted us to upgrade to the newest release. There are times when I play a mood previously used, and I can’t hear anything except one or two of the elements when they trigger. It’s never the enduring elements - only the ones that play quickly until triggered again. Enduring music and background sound effects are just gone (this happens rarely - I usually just can’t hear anything at all).

Global one shots still work (I use the Fantasy Grounds Sounds Extension (not DoE, the one by mattekure - these trigger as normal).

I first noticed the problem when clicking on a pin trigger I had placed in Fantasy Grounds. I then checked to see if it happens when starting sounds from the Master Control Panel, and found the same difficulty. Also, when in Fantasy Grounds, I always place a ‘stop all’ pin on every map, and use it before starting a new mood.

I’m running everything exactly as I have for months, and I can definitively say it began after the last update.

Bump. Anyone else with this problem? Anyone able to reproduce? I’m getting tired of reinstalling before every session.

Yeah. This is a weird one. We have had zero other reports of this, so we are definitely looking for something unique to your machine… which is always a pain!

Do also note that you posted first on Friday, then our dev team had their weekend… AND we are pretty light on Mondays… so this will get a look at sometime this week by people who might know what they are talking about.

So stay tuned… and THANKS for your patience.

My current thoughts… might something be messing with (cleaning) (protecting) your Cache?

What antivirus/malware things are you running?

@j.m.samsa My first thought was also that the online player thinks it already has these files in its cache, but it is unable to re-open those files from the cache on subsequent app launches.

An upcoming version of the app will have a clear cache button, but you could test this yourself by manually deleting this directory (on Windows):

C:\Users\{USERNAME}\AppData\LocalLow\Syrinscape\Syrinscape Online Player\SoundsetCreator\Cache

If that works, we might be more confident that something is blocking access on subsequent app launches but allowing access to files written by a running process.

Thanks for pointing me in that direction.

The was an old folder there named Syrinscape that was dated 7/11/19, that would not allow me to access it with a ‘folder not found’ error.

I deleted that folder, uninstalled, reinstalled. There is a new folder there, dated for today, and the problem is resolved.

Thanks for the assistance!


Oh my gosh! Yay!

Thanks for persisting @j.m.samsa
Thanks for your help @sonofconan