Oneshot created in Creator not appearing in Player


#1

I have use the Online Creator to create my own soundsets with no problems, including adding oneshots, and global oneshots etc.
However, I have just added a oneshot to a soundset in the creator, and it adds ok in the creator and plays fine etc, but when I bring up the soundset in the player, the one shot doesn’t appear.
I’ve re-loaded the soundset in the player (and checked it isn’t flagged as needing update), and other, later changes have appeared in the soundset, but the oneshot element is not appearing.

Is it because I am using the fantasy player, and maybe the oneshot element is from the sci-fi samples, maybe? I haven’t seen anything to indicate the source of the sample, or whether this would create a problem?

The oneshot I have created is based on the “teleportation” oneshot element, which uses the Teleport Spell__strange-teleport-sound sample (no other samples in the element).

(I have just tried copying that element to a different soundset, that already has existing oneshots in it, and it doesn’t appear, but I also tried copying a different oneshot that DOES appear in one soundset, into another, and that doesn’t appear either, so maybe something new has been introduced very recently that stops all new oneshots appearing in the player?)

FYI, if it helps, the soundsets I am playing with are called BO - FF Druid Circle, and BO - FF Grove


#2

After this happening for a while, I gave up, and have, a couple of days later, returned to it. Initially it was doing the same thing. Then I changed something else in the soundset in the creator (deleted another element) and re-installed it in the player (after waiting 5 minutes or so) and that update did not carry across either, so I put it down to the server not refreshing the soundset properly. However, when I next re-installed that soundset, it all updated fine - both the new change (deleted element) and the previous problem (oneshot not appearing) were now working in the player.
However, I changes I am making to another soundset are not carrying across (these are days-old changes that are correct in the creator, but not showing in the player), but I guess this could all be down to teething problems with saving stuff on the server, and co-ordinating it with the player?
(Note, when I say re-install in the player, I do delete the data and re-install - I don’t wait for an update to be flagged)

So it may just be teething problems with the new online creator? Though I’ve been using it for a week and not hit this problem until a couple of days ago.


#3

@Brother_Oak thanks for your updated feedback. Ensuring that changes made in the creator are being made available to the genre players is a near term priority, so I’ll be taking another look at this soon.

In the meantime, we recently made some changes that should expose the current “snapshot status” (a snapshot is what the genre player needs to download and install) e.g. via showing a spinner icon after the soundset title for soundsets that have been modified and are waiting in the queue to be processed.

Also, for soundsets that failed to process for some reason should also show an error explaining why (if possible).

Are you saying that still, after making a change to a soundset in the creator you can see the spinner icon (pending snapshot) and then you see the spinner icon disappear, and no error icon, which should mean the snapshot was prepared successfully, but it still does not show up in the genre player?


#4

Thanks for the response @sonofconan. I went back to look at this just now, to check out your query.
I tried to reload (in the player) the soundset that was still causing an issue - again, it reloaded but without the oneshot that was in the creator (this was without me updating anything in the creator - no spinning wheels or similar).
I then made some updates in the creator - to that soundset (adding another oneshot) and another soundset (again, adding a oneshot) and waited for the spinning wheels to stop spinning… and waited… and waited. It has now been about 30 minutes, and the spinning wheels for both soundsets are still spinning. I did reload them in the player and they reloaded without the changes.
So maybe the problem is actually that the creator changes aren’t being saved properly - the spinners may just be stuck in an endless loop. (Note one soundset is quite small - about 16 elements, the other is larger - about 60 elements)

It definitely used to work fine for me - I have successfully created around 20 or so soundsets with multiple elements etc before I hit this issue. Maybe it is specific to my account and something is blocking the saves?

If the spinners stop spinning, I’ll let you know!


#5

Still spinning after an hour.

I also created a new soundset, containing a single element. That got a spinner too, and has been spinning, alongside the other two soundsets, for about 30 minutes so far. When I went to my campaign manager, I could see the new soundset in the list. I added it to one of my campaigns, but it has yet to appear in the player.

Definitely looks like saves from the creator are now blocked for me :frowning:


#6

I’ve just retried this morning (about 16h after my last post) and it now seems to be working - I reloaded the changed soundsets in the player, and the changes all appeared. I then made a few more changes in the creator - the spinners disappeared after a minute or two and the changes carried across ok when I next reloaded in the player.
Saves still seem to be taking a lot longer than they used to, but at least it seems to be slow, rather than blocked.


#7

@Brother_Oak thanks for your continued feedback. Something is definitely still not right and I’ll keep working on it.


#8

Hi all … I am very very new to the creator and very much a noob on this topic in here. However, I have also encountered the spinning icons. I sent a support email in and Benjamin was nice enough to reply himself. He did suggest I post into the forum as well, so here I am. I am able to create new campaigns and have them show up in my local player (my test player is a Windows version of the Fantasy player) but what I cannot do is find any of the new Soundsets I’ve created to add them to my new campaign. So I have not yet been able to tests anything I’ve tried.

I currently have two new Soundsets, one I called “Joe’s battle (custom 4)” and the other is just “Untitled.” both are displaying the spinning icon and report in a pop-up “Preparing download for fantasy player”

My second question is more training/learning related. I watched Benjamin’s videos on the Creator app and I see that they are related to the prior player. I think in most cases the functionality is present just different. I think what may be happening here is I am confusing a possible technical delay present in the new version with not understanding the steps. Can anyone point me to a forum post where the changes between old and new have been highlighted?

Thanks so much!


#9

@jbakter I’ve just had a look at those two soundsets and I believe they have now been processed and should be showing up in the genre players. Can you tell me if that is the case for you?

Apologies for the delay and confusion. If you see the spinner next to the soundset name, and the tooltip says it is preparing a snapshot, I believe that information is accurate.

Unfortunately it does not tell you where in the queue your soundset is. But if there is an actual error when it does get to your soundset, it will show an error instead of the spinner.

There do appear to be some issues causing significant delays in processing soundsets, and we are currently investigating and making improvements in that area.

Here’s a topic in the creator category that will list notable changes and improvements to the creator as we release them going forward:

https://forum.syrinscape.com/t/notable-online-player-creator-beta-updates/6240/4

I’ve also just updated it to include the biggest changes vs the legacy creator.


#10

@sonofconan thanks for that. I did see, almost immediately after posting this, that they completed (and then showed up in the player). Funny it took like 2 days for that to happen. I appreciate you and Benjamin responding so quick, I think it is working for me as well as it is for anyone (not saying it is a problem, just the spinning icons and what not, plus who knows what the community has uploaded). I’ll keep at it in the Admin. Thank you for the link as well!