New sample imported but can't find it in Samples list


#1

I’ve created a new .wav file and imported it. But it doesn’t show up in the list, nor does search find it.

Repro:

  1. Found sound effect on Youtube.
  2. Recorded sound effect using Audacity and exported to WAV 44100, 16-bit, stereo (WAV (Microsoft) signed 16-bit PCM).
  3. Used Windows properties to remove metadata.
  4. Confirmed in Audacity that there are zero metadata.
  5. In Syrinscape SoundSet Creator, went to Sample Library, clicked folder icon.
  6. Found new sample file: lizard-cry.wav, checked box, clicked Import samples.
  7. Windows randomly open/close too fast to see what they say.
  8. Sample Import box opens and says Imported c:\SoundSamples\lizard-cry.wav.
  9. Click Close to close that box.
  10. In the Sample LIbrary Search box, type lizard-cry.

Actual results:
Nothing in the search results changes. Still lists all the samples (starting with a big deep angry pig monster). Lizard-cry is not in the list.

Expected results
Lizard-cry should show up in the search results all by itself.

I cannot find the new sample lizard-cry anywhere in Syrinscape Set Creator.

I’ve used a variety of different file names, all with the same results.

I’ve read through many other threads with similar problems. I’ve confirmed the WAV file 44100 stereo and zero metadata. I’ve shut down SSC and restarted.

Anybody have any idea what’s wrong here?


#2

Is anyone in support monitoring these posts? I’ve also sent support an email and received no response. Is this product still supported?


#3

From how you describe your method, the import should have gone flawlessly. Unfortunately, this seems to be a local problem, so tracking it can be difficult.

It is possible, that the sample is way to far down on the list. This is a flaw, that sometimes happens with the search algorithm (and will be better, once the next creator version is released). Have you tried giving some ridiculous file name to the sample, something unique that doesn’t show up in the creator so far?

Is this the only sample you have problems with? Have you tried to import other samples using the same method?

If we have no luck with these methods, we would have to browse the data base of samples. It is located at c:\users*yourname*\AppData\Local\Syrinscape\Syrinscape Soundset Creator and is called db.sqlite3 - best open it with a free database browser like DB Browser for SQLite. Go to browse data and find the soundset_samples table. Once chosen, go to the last column and try to find your sample. If everything went flawlessly, you should find it there.

Sorry for the inconvenience and the long wait, we’re currently building lots of stuff and preparing for con season. Your email may have been accidently overlooked and we’re very sorry about that. Good thing you reached out again on the forums! :slight_smile:

And yes, the app is still supported, very much so.

Let me know the results of the above, so we can figure out, where the problem is.


#4

Derp! Sorry I missed your support email! Let’s help you here anyway.

  1. This is the encoder encoding your file. Normal.

hmmm… mysterious…

How long is the sample?


#5

Thanks, Benjamin. Chris from support replied in email. His suggestions/tests helped me figure out that using dash - is the problem. If the sample name includes a dash (-), it is successfully imported into the soundset_sample database, but the Creator search functionality can’t find it. The same holds true for underscore _.

So, lizard-cry does not work.
Lizard_cry does not work.

But lizardcry works.

Is there a naming convention doc that this info can be added to?

Thanks!


#6

UPDATE!

I was wrong. After 30 minutes I went back and searched again for “lizard” and got no results, even though I searched on it 30 minutes ago and found them. However, now I can search for “cry” and I find lizard-cry.

Syrinscape guys, there is seriously something wrong with your custom samples db search functionality. It’s inconsistent to the point of not being usable.

The main reason I got SSC was to be able to import my own sounds. This bug is a big headache. Please fix it ASAP.


#7

We hear you.

Seriously, give us about 14 days and you’ll have a completely new shiny version of the creator with a LOT of things improved a GREAT deal!

THEN, with our new dev rollout setup, we will be able to FAR more easily make incremental improvements (based on continued user feedback of just this kind).

So… keep it coming! :slight_smile:


#8

I didn’t know you had a new version coming out. I look forward to it. Two weeks is no problem. Thanks!


#9

We are doing final internal testing this week. It’s looking good to go! :slight_smile:


#10

Hey, Benjamin, any update on the release of the new version?


#11

@erik The new (online) SoundSet Creator was just soft launched a few days ago and is available now at https://www.syrinscape.com/online/master/

You’ll also need to download and run/link the Online Player app on a mobile/desktop from https://www.syrinscape.com/online/

To import samples now, open the element playlist property inspector and click the cloud upload icon.

We’re still working out a few kinks, so please let us know how you go.