Moods with stand-alone music


#1

Hi all!

After over a year of subscription, I finally started playing around with the creator!

I am trying to create a soundset for cities. I uploaded several elements (each one with a track for a different coty), and added a mood with generic city noises.
However, I can’t seem to play the track with the mood. Once I play one, the other turns off.

Is there a way to play the mood as a background to a music element?

Thank you!


#2

Moods are a preset collection of sounds, so if you start a mood all other sounds will stop. If you want you music to play with that mood then you simply need to include the music element into the mood, then when you start the mood it will play all of the ambience and the music.

Does that make sense?


#3

Not really.
I mean, I understand now HOW it works, but that is pretty basic functionality not to have.
Here’s an example:
I have a list called “Villages”. Inside are several elements with music, each is the theme for a different village.
Now I want to add a generic “farm animals” background.
The way it should normally work is to have a “mood” with “Farm animal” sfx and oneshots, and have that play in the background.

The way I need to do it now is basically to create a different “Mood” for each village. That is a lot of work for something so simple as adding generic background noises to some music :frowning:


#4

Start your mood and then start the music element that you want to add. You can add as many elements on top of an active mood as you want but starting a new mood will end all elements. You just need to trigger the sounds in the correct order.

Moods are designed so that when you start one it fades out any actively playing sounds and brings in the new mood. Everytime you start a new mood it basically clears all active tracks and triggers the new presets, otherwise you wouldn’t be able to use moods to change scenes


#5

Oh, ok. I see how it works!
Thanks!

There is an issue with the interface though - when I start the music track, the mood “light” is turned off. The mood is still playing in the background, but the highlight that usually tells me the mood is active is turned off. If I press it again, instead of turning off the mood, it lights it up again, but it keeps playing, so I need to press it again.

I’m not sure if it’s a bug or a feature :stuck_out_tongue:


#6

The light is turning off because you have added tracks on top. That preset mood is no longer playing, you’ve altered it from its original state. If you wanted the mood light on then you would need to save the music as part of the original mood. You can do that in the Creator or on the fly within the app by pressing the + symbol and giving your new mood a name


#7

Ah, that makes A LOT of sense! Thanks!
So basically because I added a track, it’s no longer that mood, but it keeps all tracks playing.
Makes sense!