Minion connected to online master, but no sound


#1

Hi folks - I’m running into an issue with the online player. All of my players, except for one, are up and running with their minions. One player is showing as connected to the game, but they can’t hear any sounds. All other sound on their machine (system noises, Spotify, Discord) are working fine.

Any ideas what could be causing this?

Thanks in advance for your help!


#2

There could be a few reasons for this, the main two being are they connected to your game and the volume. Make sure that they have accepted the invite to join your game. By default the App will have them as the games master so that they can hear sounds that they trigger. They will need to click the invite link and the App should then show your name or nickname.

Also make sure that they have the volume slider for the Online Player set to at least halfway and that in system preferences “volume mixer” they have Syrinscape turned up and unmuted.

Does that seem to make any difference?

This VIDEO might also help :slight_smile:


#3

I also have the same problem minions can not here any audio. I tried by making a minion account on my android device, i see my minion is connected can not hear the audio playing from my game master account even though both online players show the minion account connected to the game master. Tried using this with my campaign last week all players who connected also could not hear audio on there devices.


#4

Having the same issue. I have three players, all three can connect, my master console shows the players connected, as done my online player, but I have one player than doesn’t get sound.

Her online player shows connected, has my name in the Game Master fields, but plays no sounds, no matter the volume. Other applications work fine (YouTube, Pandora, Discord, etc.).

She is running Windows 10 with a fresh (45 minutes ago) install of the Online Player.


#5

I can’t get it to work for my players either. Not sure what I am doing wrong, or if it just happens to be down?


#6

I’ve been having this same problem for the last few nights, and think I have found at least a partial solution.

We’ve recently switched to Foundry VTT - up until then, we’ve been using Fantasy Grounds (both C and U), and piping the music from an instance of the online player running on my computer through Cleanfeed. In an attempt to get better sound quality, I had everyone download the Syrinscape Online Player.

The first night we used it, 4/5 players were able to connect and hear - I just had a mood running (Witchwood), and didn’t use any of of the global one shots, since we were just getting settled into making character sheets and prepping to use Foundry. The player who couldn’t hear anything logged in after I had started the music. Everyone else already had the player running.

The next night, the same group got together. This time, only one person was able to hear. She had started up the Online Player before I had on my computer, and she was fine - she could hear the WItchwood music when I turned it on.

Everyone else in the group, couldn’t hear anything when they logged into the Online Player. I kept trying to have them reconnect, make sure their volume was up and re-register the device they were listening on.

Tonight, I got several of the players together, and set up another account and put the online player on my laptop. I had started playing Witchwood before everyone connected. The music wouldn’t come through on my laptop or on my players’ computers - I could see them connect, but they didn’t see the waveform, and did not see the graphic for Witchwood. I hit a global one shot, and everyone heard it just fine.

From there, I stopped the Witchwood music, and restarted it - and lo and behold, everyone could hear. While it was playing, I had one player disconnect and reconnect - again, the music was gone, but they could hear global one shots.

It seems that whatever call the program makes to the Master doesn’t get an answer when something like a mood is already playing. One shots come through, but the information for moods only populates and plays if I stop and restart the mood after someone joins.

Also, you must port forward port 7977, or your players may have difficulty connecting.

Is this expected behavior?

Hope it helps anyone who was having difficulty.


#7

@j.m.samsa Yes, players who connect will only respond to new play/stop commands sent by the GM after they are connected. They will not start already playing elements (out of sync with everyone else), and we don’t currently have the ability to have new players start all active elements from a midway point.

As the GM, you can stop and restart a mood to trigger some activity in new players. The stop will begin to fade audio out, and the subsequent play (within 3 seconds) will fade it back in without actually stopping. But the new player may be out of sync until a new mood is played.

You do not need to open port 7977 in your router. Port 7977 was used by the legacy creator and earlier versions of the online player. However even with the earlier versions of the online player, this was an outbound connection to our server on port 7977 and port forwarding is generally only required for inbound connections.


#8

We basically had two options:

  1. new players get the current MOOD that is playing already, but all their sounds are out of sync (and may cause confusion) until the DM hits a new MOOD.
  2. new players don’t get any of the sounds that are already playing, but will get properly synchronised sound once they do (when the DM hits a MOOD)

We went with Option 2)

Option 1) is possible… but not what we went for. :slight_smile:

Thoughts, @j.m.samsa?

[EDIT: corrected getting my numbers backwards!]