Made Soundsets yesterday, still not showing up in the app


#1

I made a new soundset with a few moods with the master interface over the last couple of days. Yesterday I got everything finalized so I could use it today and tomorrow for our game. I bluetooth with my phone to a speaker near where we play and play my soundsets over the speaker. The problem is that the soundsets are still in the state they were in 2 days ago on the app, not updated to the finished state from yesterday’s work. I’ve tried the “reload” button in the app and it does nothing. I emailed support and haven’t heard back. Am I missing something? Is there a “save” button I’m missing somewhere? I can understand and hour or two delay since there is a lot that goes on behind the scenes, but it’s been 24 hours now and my app still isn’t updated. What am I doing wrong here? Or do I just need to have everything done a week in advance to make sure it’s usable by the day I need to use it?


Questions about making custom soundsets
#2

If you uploaded it before and I shared the same name it doesn’t get rid of the old version. Look for one with the same name but (1) behind it or a duplicate.


#3

@beanverd there should only be about a 5-10 minute delay after making a change in the creator and being able to download and install an updated version of that soundset in the genre players. When you say that the soundsets are still in the same state, do you mean the new soundset is not appearing in the soundset list on the left hand side at all? Can you tell me the name of the soundset you are talking about so I can investigate?


#4

I have one called Nightstone that I created for my players’ visit to Nightstone. I uploaded some of my own (copy-written) music, so I didn’t publish it for others to use or anything. When I first started messing with it (2 days ago) I had 2 moods in the soundset. I continued work on it yesterday and it still hadn’t shown up in the Tabletop app. I added a few more moods and tweaked the ones I made the day before. Today I went back to it, tweaking things, and the first days’ work (2 moods) showed up in the app on my phone.

Since I posted this, the rest of the moods have shown up (after I uninstalled the app and reinstalled it a couple of times).

I think I must be doing something wrong. For reference, I am using the ‘Syrinscape: Tabletop and RPG Sound’ app on android and my soundset is set to ‘fantasy’. I see a Sci-Fi app on the app store, but not a fantasy-specific one. Should I be saving the soundsets as ‘Board Game’ instead of fantasy maybe?

I do LOVE this app, and the master interface is brilliant once you get it figured out. I taught myself by clicking around in it for a while, and by today I was flying through tweaks and changes super quickly because it all just kind of works.

While I’ve got you here, I’ll tack on another question: is it possible to have one element be set to different settings in different moods? For example, I made a crypt mood and I was hoping I could have the church bells be set to 3d audio and farther in the distance for when my players are in the crypt. If not, I can always just duplicate the element. Thanks so much!


#5

@beanverd Glad they showed up eventually, but uninstalling and reinstalling the app should not be required, and it should not take that long for your changes to become available. It’s possible there was a backlog of soundsets and samples being processed on the server, but even then I would not expect it to take more than half an hour.

When they did show up, did the fantasy player tell you that an update was available and ask you to install it? Or did you uninstall/reinstall the soundset?

You can use any of the genre players (fantasy, sci-fi, board game). You just need to set the “category” field in the creator to match the genre player you want to use.

I’ll do some testing to see if I can reproduce an issue with genre players receiving updates from the creator. Please let me know if you are still experiencing a long delay.

Regarding your other question, you can only set whether an element plays with a mood and its volume. To tweak anything else, you should duplicate the element and set one to play in the first mood and the other to play in the second mood.


#6

Yes @beanverd Elements are cheap, and don’t really take up any memory or anything, so feel free to duplicate them and set different reverbs and timings and distances and whatever you may need, then play the ones you need in the moods as you need them! :slight_smile:


#7

Okay, I’ve been really busy and I wanted to test a bit more before updating this post. I made a few changes (just turning off some elements in certain moods in my soundset) a few hours ago, and then I’ve reloaded the app and restarted the app a few times, and those elements are still turning on with the mood.

To your question; the app didn’t tell me an update was available or ask me to install anything. I’m planning on changing the name of the soundset in the master interface to something more unique and making a couple more changes tomorrow when I get some time to mess with it a bit more.

Side note: my players LOVED the soundsets. Before today I had mostly been using youtube playlists and google music playlists, so them hearing the church bells I was describing, the worgs snarling, and cute little goblin grunts really made an impact on them. Thank you both so much for all the help!


#8

Following this, because I have the same issue with updated Soundsets not showing up as updates in the player.


#9

Long delay, but an update: I made some changes to my soundsets probably 4 days ago and when I tried to use the app yesterday, reloading wouldn’t push the updates to my app (on my phone or tablet). I ended up reinstalling before our D&D game and the updates came through once I reinstalled the app and soundsets. Any idea what’s going on?


#10

Sooo… for everyone seeing this:

  1. Go to settings
  2. CLEAR DATA for the SoundSet you are trying to update
  3. Reinstall in the normal way

Do you see the latest version now?

Note: it can be useful to do something distinctive and recognizable to your SoundSet to be sure to be sure (eg change an element name or something)

Let me know if this works…

Also = we are working on Updates getting pushed properly = weirdness happening!


#11

@beanverd @OrangeLantern I did some testing on this issue yesterday and today.

I am unable to consistently reproduce a scenario where soundsets updated in the creator are NOT marked as having an update available in the genre players.

It does sometimes take a while, which makes it difficult to test or be sure if something has gone wrong or still processing.

The task that prepares snapshots for updated soundsets runs every 5 minutes, and it can take a few minutes to prepare snapshots for a given soundset, and there might be several soundsets that need new snapshots.

All this does not mean there’s no problem, just that I’ve been unable to consistently reproduce a failing test case so far.

I hope to implement a change in the near future that exposes some additional metadata in the master interface to indicate when a soundset has been updated and needs a new snapshot (for genre players). And perhaps a button you can click to prepare a new snapshot on demand.

In the meantime, if you are sure it’s been more than 10 minutes since you made a change in the creator, and it still hasn’t shown up as an update in the genre player, you should be able to force the genre player to install the latest snapshot:

  • Clear the existing soundset data (via settings)
  • Wait 1 minute (2 refresh cycles) for available soundset data to update
  • Reinstall the soundset in the usual way

Note that changing the SOUNDSET name will show up in the genre player even before a new snapshot has been prepared and without reinstalling anything. But changing an ELEMENT name will only take effect in the genre player after a new snapshot has been downloaded and installed.


Soundsets not showing up?
#12

I was able to solve this myself, in a way. I am using the scifi player and flagging the created soundsets as “science fiction” helped pushing the updates to the player. It seems you can only get soundset updates if the linked soundset is of the same type as the player.

I wonder if this applies to the official soundsets too.


#13

You always need to pick which genre you want the soundset to be, ie. fantasy?, sci-I or board game, otherwise the server won’t know which of the standalone Players the soundset belongs to. Just like we we publish new content, it by default will appear in just one of the Players.


#14

Thanks again for all of the help! I made some changes to a soundset (added some new music and an accompanying mood) and about 30 minutes later, tried uninstalling the soundset, waiting 5 minutes, and then reinstalling the soundset, and it still didn’t show the new mood or music. I’ve tried a couple more times since then with no success. I then tried reinstalling the app completely (about an hour after making the final changes to the soundset) and the music/mood are still not showing up.


#15

I do most of my game prep (like today) the day of the session (4-8 hours before the session, usually) so if I could find a way to be able to work on it in the morning and have it show up by evening even, I would be ecstatic. Otherwise I have to work on it a couple of days in advance.


#16

@beanverd Apologies for this. There was an issue that resulted in the accumulation of a large backlog of snapshots that we needed to prepare. It looks like your soundset snapshot was prepared about half an hour ago. I’m going to keep monitoring this process and improving it, and improving your visibility into the status of your soundsets, as a priority.


#17

It updated before our game, so all is well! I’ll start making my changes the day before for now, it’s really not a huge deal. I was only doing it day-of out of laziness…