MacOS Syrinscape Player unusueable - RESOLVED


#1

Recently changed hardware from a 6 year old MacBook Pro to a 2020 model, same OS version (10.15 Catalina). I redownloaded the Fantasy player, but found that on this Mac, the user interface doesn’t respond to pointer clicks or drags. Certain controls like downloading packages work, but to search i have to use keyboard controls (tab and shift tab and the app isn’t written well to support that. none of the volume controls can be adjusted reliably- the app is effectively useless for no reason that I can tell. the Os level is the same, the hardware differs, but not in a way i can see doing something like this. No other app is giving me similar trouble.

on a somewhat related note, this app is a skeaumorphic mess: I know you want to be evocative, but font choices, backgrounds, and obscuring layouts all really detract from making it accessible and user friendly. Mind i could make it work, on the old machine at least, but not on this one- any ideas?


#2

@arkanjil That sounds very strange. Same Syrinscape and OS versions, on different Apple hardware, should work the same. I run Syrinscape macOS 10.15 Catalina all the time and have not seen or heard a report like this before.

Here are a few things you can try to troubleshoot:

  • Enable the guest account via System Preferences > Users & Groups > Guest User > [x] Allow guests to log into this computer. Log into the guest account and run the app. Or create a new test user account and run the app as the test user. This can help eliminate the possibility of something local to your computer account (preferences or startup items) interfering.
  • Uninstall with AppCleaner (free) that finds and removes related files as well as the app bundle, then reinstall.
  • Look in /Library/LaunchAgents, /Library/LaunchDaemons and /Library/StartupItems for anything that might be interfering.

#3

That’s a clever trick. Will try it and report back. Thank you for the quick reply.


#4

An update:

I’ve not been able to test with the guest account, as I can’t reboot- a dupe file finder has been processing a big drive, and its not done yet after 2 days. I went back into the Syrinscape app and kept poking at it to suss out any pattern, and noticed that the unresponsive controls were only at the top and bottom of the window- and they found that they were responsive, but the click zones were floating above or below the actual button/textbox images. Then I noticed that the app was loading as full screen mode- I use Mission Control to flip through multiple windows quickly while running my game tables. When I managed to get that turned off, the click zones started mapping properly again.

So the issue refined appears to be that the MacOS Syrinscape app is useable, but doesn’t properly scale up on a MBP Pro 16" display set at default resolution (3072 x 1920), but only while in full screen mode. the app does work as expected if not in full screen mode, and it works as expected on a secondary monitor attached to the same Mac in and out of full screen mode (it is an apple thunderbolt display on a USB C to thunderbolt adaptor, resolution 2550 x 1440).

Mind, the other reason why I’ve been running your app in full screen is because the skeuomorphism makes it difficult to read to my old eyes. Given the obscurity and how well it works otherwise, this very specific issue is nuisance level at best- I wouldn’t even ding your app for it on an app review, if such were available. Should they ever uprev the app, all I would ask is that they at least consider visual accessibility in the design- better keyboard support, bigger fonts, less obscuring backgrounds and such. not many really need this sort of thing, but we really do appreciate it when they do.

One can hope, je? Thank you for the quick response, and keep up the good work.


#5

@arkanjil Thanks for your detailed update. I have confirmed the issue here on my own 16" MBP. I’ll add a ticket for this bug to our queue. In the meantime, you should be able to Opt-Click the green zoom button to make it fill the screen without going “full screen”, and also you should be able to increase the zoom level up to 200% from the settings screen to increase font sizes. Unfortunately there is not currently a high contrast option, but I’ll also create a ticket to review accessibility.