Mac Desktop and iOS Issues for Syrinscape Online


#1

Hey there,

I’ve been trying to get Syrinscape Online going on my MacBook Pro and iPhone and it is working on neither.

The iOS version gets hung up before even getting to the link device screen.

The desktop mac version will not open. I get a system alert saying that Apple cannot check it for malicious software. (see attached screenshot)


#2

Hi @adrian.kostic

Sorry about the copy and past from our FAQ… but this is the info you need. :slight_smile:

We have many people using Syrinscape on Catalina, but, yes, it objects a bit with a few warnings and often blocks the first run.

First give this a try:

  1. Shutdown Syrinscape completely
  2. Restart your system
  3. Restart Syrinscape

If you have no luck with that, then check you are running it the best way for the OS:

  1. download the DMG and drag the app to /Applications folder (ie don’t run it from inside the DMG)
  2. right click and select open instead of double clicking to launch the first time
  3. if Catalina asks for additional weird permissions (eg to monitor keyboard input), you can deny… We think this is due to the version of Unity this build is running on, and we do NOT and do NOT need to monitor keyboard input while the app is not active
  4. if it appears to be stuck, quit and re-launch the same way
    This is an issue we are working on, and it will be fixed with our next released version.

Let us know how you go! :rabbit2:


#3

No worries about the cut/paste.

Tried right-click to open (I’ve run into that workaround for other apps) but I still get the same “malicious software” message. After trying it this way 3 times I could finally open the app. However, all I get is this (see attached). It is the same screen I get when trying to open the app on my iPhone.


#4

That message usually means something is blocking Syrinscape’s access to the server, which in this case looks like it may be your O/S wrongly flagging Syrinscape as malicious software. Normally when you get these messages you should also get an option to run anyway, are you seeing that on the messages that you get? With Catalina you need to ignore all of the warnings and force it to allow Syrinscape to run.Once it’s sucessfully done so it should then let you run it every time.

I’ve also just given your account a gentle lick and reset your devices, just in case that helps


#5

I would try again with the instructions directly above your post. Consider restarting your system as well. Most people find if they careful follow those instructions then it works after a couple of goes…

I swear… Catalina!!! :hammer::crossed_swords:


#6

Huzzah!

I have no idea why but upon restarting the system and trying to open the app a couple more times it worked! I was able to sync up my iphone and desktop and things seem to be working.

Thanks for the help. I have some other questions but i’ll go through the forums and video walkthroughs before pestering you guys with them.


#7

Excellent! I blame actual goblins! Glad it’s all working now though :slight_smile:


#8

ita flagging the file because it has code for key stroke logging in the file. when will the next update for the beta happen? I was told this will be eliminated with that update


#9

@mcoronaj22 I can only say “soon”. Most of the issues we have found during testing have been fixed, but there are a few outstanding and we are testing several platforms. However, you can just click Deny when Catalina requests permission to monitor key strokes. As far as I know, the app still works fine without that permission.