GPU pegged - Online Player Master Control


#1

Greetings,

I enjoy Syrinscape and I’ve been a SuperSyrin Subscriber for a few months. I really enjoy the Online Player and the Master Control Interface via the web browser.

But, can the Master Control Interface be optimized such that it doesn’t take a lot of graphics processing to design sound sets and run sounds from it? Or can you please provide an option to turn off the graphics associated with designing and running sound? The swirling graphics that represent each sample being played is nice to have but it’s hard on my GPU.

I run multiple D&D games a week over zoom during this settler in place period. The GPU on my laptop (Inspiron 15 7000 Series) can barely keep up with the graphics on the website. Syrinscape combined with zoom creates a lag that makes the sound elements a chore instead of a pleasant addition to the game.

I’m hoping for a better response than: buy a better gaming laptop/desktop or run sound from another device other than the laptop. After all, I’m not trying to run a visually compelling video game. I’m just trying to create and run sound sets.

Thank you.


#2

Thanks for this feedback. Performance is important to us and something that we do continually monitor and improve where we can. I can’t make any promises on timing, but I do hope to be taking another look at the Master Interface soon and I will make sure that we look into this.

In the meantime, could you confirm for me if it is the Master Interface or the Online Player (app) that is causing high GPU utilisation?

You could try running the app on a mobile device instead of on the same laptop as the Master Interface to see if GPU utilisation drops, or remains the same?


#3

Thank you for getting back with me. According to multiple tests with the windows task manager, it’s the master Interface (via the browser) that is causing the high GPU utilization.

Also, when I design my sound sets, I have been running the app from my phone with headphones, and just using the master interface (via a browser) on my laptop. It is still slow and the task manager shows a spike in my CPU/GPU when a mood is executed that uses multiple elements. It appears that the animation showing samples playing for each individual elements and my pegged GPU are related.

I’ve tried chrome and firefox and have had more success with firefox because chrome seems to be heavier on the CPU regardless of syrinscape.

A work around I’ve discovered is quickly minimizing the firefox window with the master interface up after activating a mood or an element. My CPU/GPU usage drastically reduces soon after it is minimized, and I hear the sound change coming from the online player app quicker.

So for now, I can execute sound and quickly minimize the window during a game. This is not ideal because every sound change or adjustment requires more mouse clicks and attention from me during game.

Designing sound sets is still sluggish. I wish there was a way to reduce or turn off the animation in the master interface. I’m sure people with desktops or newer laptops don’t notice it as much as I do, but for people in my situation it would be nice to have the option of reducing the animation.

Many thanks.