FMOD failed to initialize - No sound

I have no sound anymore in Syrinscape.
I believe it is tied to some patch update either Windows 11 or nVidia.

Here is the error message in the player.log:
FMOD failed to initialize. This may be because your sound card is configured to give applications exclusive access, thus preventing Unity from using this device. You can change this in Control Panel > Audio Devices and Sound Themes > Playback Device > Properties > Options … : "Soundcard does not support the minimum features needed for this soundsystem (16bit stereo output). " (59)
I have tried to check as suggested in Control Panel > Audio Devices and Sound Themes > Playback Device > Properties > Options but did not manage to solve the issue.

To the best of my knowledge we have not seen this in house or had anyone else report something similar. That said, I found this thread on the Unity forums that seems relevant:

It looks like Alienware Sound Centre gets in the way while trying to be useful, and disabling that solves a broad range of issues for the folks responding to that thread.

Everything suggested there seems relatively harmless to try, other than:

downloading the “official” (and I use that word in the loosest possible terms…) Realtek reference drivers

This seems sketchy, I would not try it except as a last resort.

Run this program as an administrator

As I’m sure you are aware, most software should not need to run as administrator, and it is just risky to do so, so generally would not be something I recommend :slight_smile:

1 Like

Hi, thank you for those pointers.
Unfortunately I have tried all proposed avenues without resolution, for some reason the unity code for Syrinscape does not detect the audio device, while all other applications and games do.

I’m sure you have checked, but just to confirm, are your audio drivers up to date?

Yes everything was updated, I even uninstalled Alienware components

Okay, so do you have an MSI motherboard? In this case it seems that A-Volute has made some deals with Microsoft to get their software delivered with Windows Update:

and this has made some people somewhat upset:

So even disabling Alienware components may not remove its influence, if the drivers have been installed by Windows Update. There seem to be several different processes that conspire to keep the thing installed and active. Indeed, I do not know if there is any official way of uninstalling it at all, although several users posting there seem to have come up with work arounds.

I can not recommend you try any of these since they do not seem to be supported methods, but it may help point you at least to a cause.

Hope this helps :confused:

1 Like

Thank you for trying to help.
The motherboard is an Alienware one (now is it a rebrand of a MSI? I can’t tell).
I was able to kill Nahimic by just disabling the service, however it did not help.

I did not dig through all the posts, but it seemed that some users had some processes labelled A-Volute also running that needed to be killed. Also, just disabling the service the processes could still be in memory until you restart or kill them explicitly? And, windows could fiddle with your services configuration to turn them back on. Having not experienced this myself, I can not say for sure that this is the cause of your problem, but a bit of Googling certainly points in that direction, especially given the Alienware connection.

I’ll keep an eye out for this, but nothing I have seen so far suggests there is anything we can change in our software to fix it, and indeed it has impacted some across a wide range of applications, so I do not know if there is much else we can do. There are a lot of different combinations of Windows computers out there, we can’t be on top of them all! :desktop_computer:

Hoping you can get this resolved! :crossed_fingers:

1 Like

I did all that, I also removed the process completely, this is not the problem here.
The problem seems to lie in the fact that Syrinscape, based on its log file, is unable to find the right audio device and there is absolutely no possibility for the user to check what happens fro, the application as there is no setting like in others that would allow to point it to the right audio device.
I would hope that Syrinscape support goes beyond surfing the internet. I would also like to point out that it is not purely a Unity based as I have no such issue with other Unity based applications and games I use.
I understand I may be one of the few, but I feel based on your last comment like as I am a orphan patient is some medical center and I have to deal with it myself…
Well if I have to deal with it myself, I believe the only solution would be to continue paying for a subscription I am unable to use anymore or to stop using Syrinscape and call it quit and lose all my previous investment.

I might be misunderstanding the issue, but can you try another application like Ear Trumpet or Audio Router to force syrinscape to play to the device you want it to? I’ve used both with success but I’m not 100% sure that solves your issue.

This does not work as the Audio driver is already loaded with failure in the application shutting down the sound.