Error: Managed Return -1 - RESOLVED


#1

I apologize for the double post. I first put this in the other thread with the same title/issue, but I think that because it was marked as resolved, my post was ignored.

I’m getting a Manage Return -1 error when I start Syrinscape. My user name is a simple “Ryan” (so it’s not an issue of unusual characters in the directory name, as was suggested in the other thread) and my cache folder appears in the correct place but is blank. I tried renaming it and deleting it and then restarting but this did not resolve the issue. I don’t know what the next step is. Unstalling, deleting the registry key and reinstalling maybe? Help!

My rig uses a single SSD with Windows 10.


#2

HI @Rykara,

Soooooo… you shouldn’t be able to get that error if your Cache is Empty. I wonder if you are looking in the right spot… Wanna sent a screenshot of your explorer window?

Also: anything blocking apps writing to the cache (eg Malware protection etc?)
What virus checkers are you running? A lot of the stuff the Creator does can look pretty suspect. :smiley:

We’ll sort you out.


#3

Here you go! Sound editor was working just fine for days and then suddenly locked up on me. (The web page timed out). When I closed the app and tried relaunching, that’s when I started getting the error.


#4

Sooo @Rykara are you saying you’ve been editing SoundSets and uploading and everything?

In that case, your Cache directory being completely empty is definitely a problem.

See my screenshot. Can you find these files? Have they been quarantined by something. Same questions as before about Virus/AntiMalware checkers…

Creator%20Cache%20Files


#5

@Rykara, you’re talking about the Creator, right? And it worked for you up to one point?
Did the crash occur while you were using it or when you wanted to start it again?
Did you use some samples you created yourself or did you only use samples that came with Syrinscape?

The folder you want to have a look at has a different path. Please have a look at

c:/users/ryan/appdata/local/syrinscape/syrinscape soundset creator/

There you should see the files and folders Ben mentioned in his previous post. Can you confirm, that you have the same Content in the folder? If you do, we can take the next step into solving your problem. :smiley:


#6

@benjamin I do not have any antivirus software. My Windows Defender is set to ask for permission before installing software but is permissive otherwise.

@new_vision Ah, my mistake. Yes, I have that directory and is is populated with the same files that your screenshot shows. I am referring to the creator. I have a small handful (maybe 5?) sounds that I added to my custom soundset. They were all wav files with no metadata. I had the first few in there and working.

Edit: I figured the next logical step was to pull out the sound files I’d added and try relaunching to isolate the problematic file. I got it on the first try. The creator didn’t like the sound of frogs croaking, I guess. Thanks so much for the help, y’all!


#7

Maybe the frogs were too slimey… :slight_smile:

What about the sample rate of the frog samples? Are they 44.1kHz, 16bit, stereo?

If I am not mistaken, there should be some frogs in the swamp soundset.


#8

Yay!

Vanquished are you cruel FROGS!