Custom Moods Resetting - ON HOLD (sadly we've been unable to reproduce this one inhouse)

Hey! Just finished setting up my campaign for tomorrow night after having to move my Syrinscape program to a new computer. HOWEVER, on both systems now I’ve experienced an issue where, after putting quite a bit of time and effort into creating a large selection of “Custom Moods”, they all disappear. I had a “Custom Moods III” set up to be the entire dungeon play-through…then, after installing “DoD Vyre Banquet”, they all vanished. Gone. I tried doing a reload, nothing; closed and reopened, nothing. At this point, since the game is tomorrow night, I give up. I’m not doing it all for a third time.

Does anyone else experience this issue? If it’s just me, what am I probably doing wrong to cause it?

Thanks for the help!

I’m running Syrinscape on an iPad and what’s happening is that every time I download a new soundset, all of the custom moods I’ve created in the CURRENT session, disappear. Custom Moods created in previous sessions remain. I don’t know if this is similar to what’s happening to you. I avoid the problem by always quitting and restarting the program before downloading new sound sets. It took me a long while to figure out what was prompting the disappearance of my custom moods.

That’s exactly it! Moving forward, I’ll be sure to go through that (annoying) process to prevent the (more annoying) loss of custom soundsets. Thanks for the tip!

I don’t know what your license status is (fantasy/scifi sub, supersyrin, individual purchases), but the best solution for this is to create a soundset for yourself. If you go through the procedure to activate every element you need and then safe it in a custom mood, you might as well recreate it in the Creator and upload it for your use in the according player.

But i agree, this - probably Goblin induced - feature can be quite annoying. :wink:

OK!!! YAY!

The way bug fixes work is this:

  1. Someone reports a problem
  2. The dev team tries to reproduce the problem
  3. If the dev team can’t reproduce the problem, that’s a bit of an issue!
  4. I have, in the past tried to reproduce this, and not been able! grrr!
  5. BUT, it looks like we might have an actual more clearly defined thing here now!
  6. Thank you, @Lindsay_jarratt!
  7. I’ll give that a try… as many times as I can, until I can get it to NOT work! :smiley:
  8. @matt_owen89 I am SOOOO SORRY for your painful experiences! I’d really like to sort this one out, as soon as possible… hopefully your post and the additional comments might be the final clue we need!

*crossing ALL fingers and toes

Hi, Did anyone figure this issue out? It is happening to me right now.

Created several moods for a camaign in FG today.

Then I installed a new soundset to create a new one and the custom moods disappeared.

I have older ones created that do NOT clear when I install a new soundset.

KR
Mardragon

1 Like

@mardragon7 I don’t currently have an answer about or direct experience with custom moods disappearing from the genre players, but did you know you can now create persistent custom moods via the online player? These are stored on the server, unlike custom moods created in the genre players which are local to that device only. You can then install your custom soundset with its custom moods in all your genre player devices.

@mardragon7
Does hitting reload under settings make the Moods appear? :slight_smile:

OR is something ‘cleaning up’ your registery perhaps?

Is this on a PC or MAC?

Hi. Thank you for responding.

I posted here after finishing the preparation session last night.

I just opened the software and my “missing moods” are back. I swear Fg links to them was silent last night and trying to figure why, they did not appear, Installing a new soundset was the only possible reason at the time.

It suggest to me, that your suggestion to reload, would have worked.

Since you ask, it is a PC, not that it is relevant anymore, I just dont want a MAC linked with me as a possibility :slight_smile:

@sonofconan Genre players, Is that the software and the content I am subbed to use? I do not know anything about a online player. I use this for FG only and do not forsee I will use anything but my PC when it comes to devices.

Thank you guys for the help :slight_smile:

Was able to recreate it now.

Made snake sounds on new custom mood in DH Old Tower, Installed Zombie battle. New snake mood went away. Click Reload and it is back.

All ok.

Signing out. Cheers. :slight_smile:

Hello

I am still experiencing a bug similar to this.
Using and Samsung Tablet.

I hope you have a fix for this soon…

Yeah, this is still a huge problem for me, kind of approaching a deal breaker. I have custom moods I need to use week after week, and they keep vanishing. Recreating the same Custom Moods, esp. a lot of them, three-four-five times is driving me nuts.

I run the fantasy player on a MacBook Pro. The same thing happened when I used to run Syrinscape on an iPad.

Here are things that make Custom Moods vanish:

  1. If you create a custom moods, then update or load another sound set, the custom moods vanish. This doesn’t happen if you quit the program, then reopen the program again before updating or loading the other sound set.

  2. Whenever new sound sets are released and appear in the menu, all of my custom moods vanish.

Clicking Reload DOES NOT bring back the Custom Moods. Once they vanish, they are gone for good.

What can be done about this? This is a really old problem that’s never been addressed.

I subscribed from 2018 - 2020 and eventually cancelled my subscription because of this problem. I recently re-subscribed and I’m experiencing the same old issue.

I use the Fantasy Player and I rely heavily on Custom Moods during sessions. I like to plan out sound sets for each scene my players may encounter. Since I run a sandbox and my players are given multiple options - I prepare a lot of different sound sets and save them as Custom Moods. Some of the Custom Moods are permanent additions to the game since they’re considered the sound of a particular location the party has visited.

I contacted support a year or so ago and they stated that the Custom Moods were stored in the device’s cache - and once the cache was cleared, the Custom Moods would disappear. I was told that depending on the device, the cache could clear when it goes to sleep or upon reboot. That explanation didn’t make sense considering the fact that I had some Custom Moods saved for 2 years (on the same device) without issue.

When I ran in person games (pre-COVID), I used a MacBook Air to run the Fantasy Player and once a sound set disappeared - it was gone forever. I experienced this mid-session multiple times.

While preparing tonight’s sound sets, I experienced the vanishing Custom Moods. Luckily, I’m on a Windows 10 desktop and selecting Reload (as mentioned above) worked to restore the vanished sound sets.

Questions for the developers:

  1. Can the Custom Moods be manually backed up and manually restored in the event they disappear?

  2. Is it on the product road map to combine the functionality of the local player and the online player? Being able to save my work in the local player to the cloud would be amazing, but I do not wish to use the online player.

Hiya,

  1. No.
  2. I think you can already do what you are describing. Like this:
    a) use the Online Player to do all your prep (creating custom moods) (moving round elements) (mixing and matching content) (importing own samples)
    b) install your custom SoundSets (the ones you created in the Online Player in the Fantasy Player on the device of your choice
    c) run them from there in game

OR

d) Just use the Online Player. Is there any particular reason you don’t want to go for option d)

Helps?

Just experienced this issue this Friday.

On Thursday I went and spent about an hour creating 8 custom moods for my session. Shut down the computer. On Friday they are all gone. All of my Syrinscape prep is gone… After 3 years of some variation of this bug being around is there really no solution? Suggesting the online client is not a solution. When one of my players is running I don’t want to have to log them into my account in the browser. I don’t want to have to worry about AWS server issues causing lag. I don’t want to worry about clicking a one-shot thunder sound and having it play 5 seconds later.
I don’t want to have to run a Online client and have the master in the browser JUST so I can play custom moods for an in person game.

I stopped using Syrinscape and just stayed subscribed (so I could gain new soundscapes) while my group played online with the pandemic. I have had this bug delete all of my work multiple times in the past and I was astonished to see that it is still plaguing Syrinscape…

Miscellaneous information:
Windows 10
1.4.10-p0 - Windows

Mey @mechmike
So sorry for your lost prep time. This is a VERY rare bug that we have never been able to reliably reproduce in house. It’s most likely related to SOMETHING ‘cleaning’ your Cache, or ‘protecting’ your system on your particularly machine. So sadly, it doesn’t look like something we are going to be able to fix in the short term.

Have you considered doing this?

Here’s a video of some of useful methodologies that are possible in the Master UI. I would HIGHLY recommened at least trying it out.

I have the exact same bug.
I’ll try doing all my prep in the online player, but it is really annoying when all the custom moods reset.

As said before by others, when I download a new SoundSet all the custom moods I’ve created since I last launched the program disappear.
I’m using Syrinscape on a windows 10. What other information do you need ?