Changing soundset title in online creator - RESOLVED


#1

If I copy a soundset in the online creator, then try to change the title of the soundset, it is difficult to type a new title, as the title keeps ‘reverting’ when I type, and automatically deletes a few characters that I have just typed. I think it settles down after a while, but the general way of doing this is to select a soundset, click duplicate, then start typing the new name straight away, which doesn’t work very well.

I wonder if the auto-saving may be overwriting the title box multiple times, as you are typing into this same box.

The same problem exists if you create a new soundset, then start typing the new name straight away.

It’s a minor issue, easily work-aroundable, but thought I’d flag it in case you’re working in this area.


#2

@Brother_Oak Can you confirm this is still the case for you? There was a bug a few days ago (before you made this post) that may have been able to cause the behaviour you have reported (I saw the same thing happening with the “category” field). But I just tried myself to make a new soundset and rename it, and it appears to be working now.


#3

@Brother_Oak I think I’ve reproduced this issue. It seems to happen when you type at just the right speed.

We initiate a save half a second after the last change to a given field. So if every keystroke occurs within half a second of the last, there should be one save after you finish typing and no problem.

But if you send a keystroke after a save has been initiated but before the save has completed successfully, when the save does eventually return it will undo your subsequent change(s).

If you type slowly (half a second plus time for the save to complete successfully), there will be a save after every keystroke and no problem.

I’ve made a ticket to fix this bug.


#4

@sonofconan I just tried to reproduce and, although it happened just the once, it seemed much better than before - both for renaming a duplicate and naming a new soundset.
I tend to have the property inspector open, and when I create a new soundset, I start typing the new name immediately, when duplicating an existing soundset I quickly select the old name (with the appended “copy”) and then start typing the new name, so I do tend to enter the new name pretty quickly after creation. Previously, as I typed the new name, on multiple occasions while typing it, letters would disappear (revert to a second or two before). This time I was able to enter new names without a problem (except the once, when a letter was deleted, but that was much better than before).
Certainly much less of an annoyance now.
Thanks for the quick response!


#5

@Brother_Oak This should be fixed now! :smiley: