Ambient Noise Disappears Over Time on Zoom

While I’m posting an update to my volume cap question, another issue came up now that we just started our sessions again last night. If anyone else is screensharing SOUND ONLY on zoom, have people noticed that sound appears to come through at first and eventually stops piping through to the room? I’m guessing that this may be tied to one of a few things, but I’m just grasping at straws here:

  1. Playing for too long (2-3 hours) and zoom somehow stops broadcasting or prioritizing sound?

  2. The same as above, but related to volume on syrinscape dropping below a certain threshold? I mention this specifically because sometimes pressing a oneshot makes it bounce back.

  3. Some kind of relationship to sound only sharing being overwritten by too many people talking and then never coming back?

If others are experiencing any of this I’d appreciate the help. Again, this usually starts out fine, then just disappears toward the end of a session and has been tough to replicate (happens every session, but you need to wait a ways in usuall).

I don’t know about this example in particular, but I have heard of some instances of issues with music being suppressed on a voice call because it is considered background noise, and is suppressed (to favour the voice). It might be that over time Zoom is adapting to the sounds Syrinscape is producing and ramping up the suppression to muffle them. This may also explain why One Shots come through okay, because they break up the pattern Zoom has learned is background noise. I believe there is configuration somewhere to disable this suppression, but I could be wrong.


I ran into this before when trying to stream the sound mixed directly in with my own voice. It definitely picked some sounds up as noise for suppression and clicking off these options and “reverting to original sound” helped a bit, but again when other people talked I was told that my mic was lowered a bit and this lowered the background noise.

With Share Device Audio Only (advanced share screen option), I’m not sure that this occurs or if there is a setting that I can hit to stop noise suppression or if any dampening is occurring when others speak.

Can anyone else chime in on Ryan’s points with more information if you’ve experienced something similar and have a solution?

Ah, so you’re having Zoom grab the audio out from the device playing the sounds, rather than having them be picked up by a mic. I can’t say if the suppress background noise audio settings would apply in that situation or not. Either way, it sounds like you have tried that and it came up short. Have you checked if Syrinscape itself is producing the sounds at the volume you expect? If so, maybe contacting Zoom’s support would be an option here, to see what they think of this setup.


Correct, I’ve tried both. Initially I tried to have the mic pick it up, and it does. However, zoom filtered it out. Original sound restored this…but then the fact that zoom prioritizes speakers over other non-speakers causes problems because my mic (the DMs mic) drops off when anyone talks. And just to be clear, I did this both with the mic picking it up from my sound system and also with a mixer looping it directly into my mic input as well.

Now I’m trying the zoom share screen advanced option for audio only. This works better, but I need to restart the sounds repeatedly on a long session or they just disappear. Agreed this might be a question for zoom as well. But I’m surprised that others haven’t run into this issue. Maybe my players are just sensitive to background sound being too loud, but I’ve been asked to turn it way down repeatedly, so we’re sort of stuck at the volume we’re at now as this is comfortable for them.

Seriously NOT trying to be cheeky, but have you considered trying out the Online Player which we built specifically for this purpose? :wink:

Perfect sound quality delivered to your players, in perfect stereo? :slight_smile: No compression, no noise canceling…

Online player used to pose other problems with people not being able to hear the same thing at the same time with the random sounds etc. I’m not sure if that has been resolved or not, but I can take another look at it.

Well the online tool looks a lot better now. I looked around briefly and may have just missed it, but is there still not a common API list available? I know there is one for the sounds in and packs, but I can’t find global-volume or global-oneshot-volume in there, so I’m assuming there is another list with a few more options or is that mostly it other than global stop or whatever that is as well?

We don’t have an API surface documented for general consumption, although we encourage users interested in integrating to contact us on the support email or investigate the way the Master Interface works. In short, the CSV download with the play/stop commands, the global stop and the global volume controls are about it. Was there something else you had in mind?

Not really if that is all that was there. I did see the option to toggle the stop/play on individuals sounds and moods. I was hoping for a oneshot STOP instead of a global stop, but I don’t see an icon for that so that’s probably not there. Keeping the ambience would be nice without resetting everything just to get a stop on a fireball that never happened. That said, a 0% volume on oneshot would have the same effect I guess as long as I waited for it to finish executing before putting the volume back on. And this would be something to kill all oneshots so that I don’t have to have the specific stop API call for the oneshot I hit I guess. Also, on the control screen, a oneshot stop option would be nice. Moods you can click off and on, but sound effects when you click them a second time just restart the sound which can be frustrating.

Being able to rapid fire trigger Oneshots is an intentional feature, and I imagine can be fun with the right sounds. Doing a stop-all and then restarting a mood before the fade-outs could be close to the effect you’re looking for. That said, it sounds like you are making your own interface, in which case I think you could make it so your Oneshot play button switches to a stop while it is playing to get the effect you’re after.

Maybe some other DM DJs can respond with some other tricks, although I think I like the Oneshot volume control idea as a good workaround.

I’m specifically using the APIs via API Ninja in Streamdeck. As such adding a stop button to every API would double the necessary real estate which would be cumbersome. I agree on rapid firing them being helpful and important, but I do think a stop all oneshots isn’t a terrible idea. That said, I don’t think it is probably that high on the overall priority list and clearly folks have been getting by without it, likely with the methods you’ve mentioned above. Anyhow, I appreciate the feedback and I’ll check in for anything anyone else posts as well. Online looks a lot better than it did the last time I took a look so we’ll give that a shot and see how it works on the player side. Nice job on the APIs in general from what I’ve seen though, the volume changing and one shot firing is fast and seamless in my tests.

1 Like