502 bad gateway

Last night I tried to upload a new element mid-session, and that crashed my online control panel. After that, I only get 502 bad gateway errors trying to get to the control panel, master interface, and even https://www.syrinscape.com/ . I had to end my session early. :frowning:

@daniel.anand I’m looking into this now!

@daniel.anand The situation should be a bit better now. I found and resolved one issue, but there are still slow page loads. I will continue to monitor and investigate.

Hi there,

Adding onto this thread. Got the same error and soundsets aren’t loading. The program didn’t crash or react to anything, this happened when I opened the moment I opened the “online master” in the browser.

Hoping you’ll find a fix soon!

I also posted in another thread - soundsets are not loading, 502 Bad Gateway error.

I am getting this error too. I can play the sounds via Fantasy Grounds and Mattekurre extension, and the sliders and stop button on the web controller interface works, but get a 502 error on the soundscapes.

Not sure if relevant, but I have been refreshing the page on and off (session tonight, so wanting to be there asap when it is running again).
I am now getting “404 page not found” for link https://www.syrinscape.com/online/master/#/

Again, might be on purpose so not sure if useful, but reporting just in case it is :slight_smile:

Just an update. There is still an issue with the database performing very slowly. This is manifesting as slow page loads and API requests. In particular, loading the soundest list in the online player is often timing out.

We have increased the database capacity and increased the timeout limits while we continue to investigate the root cause of the problem.

Once the soundest list has loaded, you should still be able to navigate into soundsets and play moods/elements. Those actions might also still be a little slow, but not to the same extent as loading the soundest list and not timing out.

Integrations such as with Fantasy Grounds that are just triggering play/stop commands from a local database of URLs should also still be working, although perhaps a little slower as well.

Yep, super slow for me to load Master Control page (4 minutes here). Trying to load a soundset also takes minutes, it is barely usable as is.

It would be nice to have a status page for the Syrinscape Online service so we can see if it is the service that is down/slow, I spend a lot of time yesterday double checking my internet connection.

Good luck with the troubleshooting, and let us know when you see some progress!

1 Like

I’m in the same boat, was about to use syrinscape for the first time today in session. I hope they figure this out in the next three hours.

Do you guys think this is a couple hour problem or a couple day?

Without knowing what the problem is I can’t really give you a time frame. What I will say though is that generally @sonofconan and his team are lightning-fast when it comes to this sort of thing, so I know that they will have you back up and running as quickly as possibly and hopefully in time for your game :slight_smile:

Sweet, I get it, I’m excited due to it being the first session I was going to use the program. Good luck to the crew and thanks for the energy!

1 Like

Just want to know if there’s any new updates on this? kinda sad my game is about to start and the sound sets aren’t loading :frowning:

This is sad and annoying. This loss of performance has come out of the blue. We’ve made no changes to the database… it’s starting to look like it may be something wrong on our host (AWS).

The WHOLE dev team is working on this. It’s a normal working day here in Sydney Australia, which is nice for a change: these things usually happen at midnight on Sunday morning! :smiley:

I’m so sorry that some people’s games are being effected!

Rest assured we are working as hard as possible to get things going, and will update you here. This is the longest outage we’ve had in 12 months!!!

Can anyone channel positive energy?!? :innocent:

5 Likes

So idk if this is known but syrinscape has deleted ALL of my sound uploads. Hopefully it’ll come back

Er, yeah!!! ALL my original soundsets are GONE!
Please tell me this isn’t a side-effect of the ‘fix’!!! Or at least that it’s a temporary one!!!

Apologies for causing alarm. It is a temporary change to alleviate load issues and hopefully improve general availability while I continue to investigate.

ahhh ok! At least i know it’ll come back!