Fatal Error! Managed Return -1 - FIXED


#21

Thanks for your answer Benjamin!
I tried to run as admin, same issue.
I uninstalled and run the installer as admin, then run the program as admin, same issue.
As I installed in F:, I unistalled an tried again in C, as admin. Same issue…
There are quite a few programs using either the Local or Locallow directory, so it doesn’t seem to be a problem for them to write there…


#22

What kind of Antivirus solution do you use? It may be a possibility that your AV interferes with Syrinscape accessing those folders, God knows, why - but I won’t rule that possibility out.


#23

Yeah, it’s got to be something on your system identifying the Creator as a threat, and restricting it’s access to write to the disk. Because Syrinscape is NOT Microsoft or Apple, our software can look suspicious to malware detectors, especially with the way we, download/upload from/to the web and write to disk.

What protections are you running?


#24

I’d tell you to turn on logging, but you’re not even getting to the point where the log file is getting written so that won’t work! :-/


#25

I tried to turn off Windows Defender and reinstalled as admin (in C), and then Launched as admin. Same issue :frowning:


#26

Out of curiosity - is it a rather fresh installation of Windows 10 or is it a workstation without a lot of gaming stuff? It is possible that some runtime libraries are missing - those are usually installed with a lot of other software, but if they are missing, strange things like this can happen.


#27

It’s more than 1 year old, with a lot of stuff. A lot :wink:


#28

Hmmm, tricky. I guess yiur system is up to date aka patched?


#29

Yes, patches are installed automatically


#30

And I guess no extraordinary hard- or software? It is rather late for me now, but I will check my installation tomorrow and try to find out, what is different. Your first install was to the F: drive?


#31

Yes, I have a SSD as C drive (mostly for System) and another one as D drive for selected software (and games) needing fast access.
All other software is on F on a regular HDD.
So initially I installed the Fantasy player on F (it’s still there, working fine) and the SoundSet Creator on F as well.
Since then I uninstalled and reinstalled many times on F and on C, getting always the same error when launching.

I also tried to launch the player.exe file. It launches, says “Connecting”, then “Auto-reconnecting”, then “Connecting” and so on…


#32

Note also that the Syrinscape Fantasy Player file is also in the LocalLow directory…


#33

Okay, i dove a little into windows:

  1. So, you don’t have a folder Syrinscape Soundset Creator as subdirectory here?

C:\Users*yourwindowsname*\AppData\Local\Syrinscape

  1. Can you check if you have a registry entry at this location?

Computer\HKEY_CURRENT_USER\Software\Syrinscape\Syrinscape SoundSet Creator

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall{B75BAACA-9B16-44D1-8B51-87019B73A4FC}_is1(the last term may vary)

Computer\HKEY_USERS\S-1-5-21-2679920019-2858491859-1445178808-1001\Software\Syrinscape\Syrinscape SoundSet Creator (i also think, that this cryptic number worm may vary)

The uninstall registry key points to the creator location. I think the whole issue is somehow connected to your first install onto the F: drive. Could you check if you a) have those entries in your registry and b) if there are any file paths/locations given? There SHOULD be a directory in the /AppData/Local/ branch, otherwise there was probably something broken during your initial install.


#34
  1. I didn’t have one, I created one by hand hoping it could help but it remained empty.

  2. Yes, the 3 entries exist but no mention of directories.
    On the other hand the Fantasy player has some and it reads this way:
    C:/Users/Stéphane/AppData/LocalLow/Syrinscape/Syrinscape Fantasy Player/URI

So now I wonder if the issue may be related to my first name: Stéphane that apparently turns into Stéphane there.
Not a problem I know of for other software but?..


#35

Yes, that could totally be it! Syrinscape is a little picky regarding those special characters, I think because of the game engine used, but you will have to talk about that kind of detail with @Benjamin or @Steve.

To verify it: can you create another user with regular characters and install the creator with this user?


#36

Yes, I think you identified the source of the issue. Many Thanks!
I created another account with no special character and it worked fine, using the Local directory.

Now I hope either @Benjamin or @Steve can do something about it as using another account would be an issue for me as I use D20PRO on my Stéphane account, if I want to integrate both I need to have Syrinscape wotk on the Stéphane account.


#37

Oh my gosh! I’m glad this got fixed. Sorry I didn’t think of that one earlier!!! It’s actually in our FAQ somewhere there, too!

The European letter thing is a limitation of Unity, upon which Syrinscape is built, so it’s a hard one for us to fix.

Can you consider moving everything over to a new user account… or editing the name of the existing one? I think though the problem comes in the /user/name directory… Is there a special character there? Ask google how you might change that?!

Good luck!!! And definitely let us know if we can help more!

AND NOTE: All this will be fixed permanently when the Master Minion Player comes online at the end of the year! It’s going to be GREAT!


#38

I’m going to see if I can change the name of the existing account, even though it’s a bit scary.
I’m glad to know that it won’t be a problem anymore in the future.

Thanks!


#39

As a spaniard named José I has my share of problems with many programs due to that é.

As a Unity programmer myself I can tell you it’s a problem from the engine and it’s much easier to just use the regular e with anything related to the file system.


#40

If I remember well when I installed Win 10 I didn’t specifically put the name, I think the system used my first name without asking. I guess next time I’ll be more careful!